Change the login background

I found this, but my .xml file does not have the background string.

I want to change the login background.

The properties for GDM are defined in the distribution-specific gconf settings in /etc/gconf/gconf.xml.vendor/%gconf-tree.xml.

 To change the background image, look for:
  <dir entry=”background”>
 <entry name=”picture_filename” mtime=”1241629069″ type=”string”>
 Change the string value to the location of the background image you  want to use.  This can be either a JPG file or an XML file in the Gnome  background slideshow XML format (which does not seem to be documented).

Not seeing this answered before, I decided to take a few moments to do a quick look, hope the following gets you started…

Don’t know where you got your code (You should always post where something comes from or a guide you’re following) but nowadays openSUSE is running a subsystem called Plymouth during initial login. Plymouth manages user input (Username/Password) and therefor also the background.

Plymouth is not easily configurable with a simple text file, it’s a program which requires inspecting and possibly changing its functionality.

I didn’t spend a long time looking at various published articles on Plymouth, but here is one

Note the article is based on Debian and there are some significant differences like its syntax usage of single and double dashes preceding command options. You may find that an article based on Fedora is more accurate describing commands you can use in openSUSE without modification.

Reading the article I referenced (and trying a few commands) you’ll find that you need to first start up the Plymouth daemon, then command it to display the splash image and perhaps query. Again, YMMV .

Also, an important resource which might provide you exactly what you need (perhaps you should even start here?) is to look at the Plymouth man pages

man plymouth



This was my source.
After reading about, I decided to pass.

Too much work.

I thought it would involve pointing to a different picture file.


This was my source.
After reading about, I decided to pass.

Too much work.

I thought it would involve pointing to a different picture file.

I had always the idea that Plymouth is a bootsplash ( and has nothing to do with the theme used on the login screen by dm/kdm/gdm (except that distibution makers will probably try to use the same theme for both areas).

On 05/28/2014 03:16 PM, hcvv pecked at the keyboard and wrote:
> I had always the idea that Plymouth is a bootsplash
> ( and has nothing
> to do with the theme used on the login screen by dm/kdm/gdm (except that
> distibution makers will probably try to use the same theme for both
> areas).

I always change the setting in “Configure KDE4 Desktop” under “System
Administration”–>“Login Screen”. I think you may have to turn off
“Themed” mode.


If you are using KDE you can run:

kdesu kcmshell4 kdm

got to Theme tab and select your choice,

Install_new_theme, Remove_new_theme or Get_new_theme

I don’t know about the other DE’s sorry :wink:

It should not be necessary to run it as root.
Just do it as user (via the standard “Configure Desktop”/“Systemsettings” entry in K-Menu) and you will get asked for the root password when saving the changes.

But as I understand it, the OP is talking about the GDM login screen.

No idea there as well (the link mentioned by the OP is for an old version, 2.24, where 13.1 has 3.10) , but the background picture seems to be located in /usr/share/gdm/greeter/images/distributor.svg. Try to overwrite this.
But your change will get lost on updates of course.

At first i did not do that as root but nothing happend after i change the background :(. I had a ask around in suse channel -kde folks and one of them pointed to me how to do it like that so i guess i cannot really say why it needs to be done as root, but try it as a normal user and see:) or they had already a fix, maybe :slight_smile:

If you click on “Apply” a dialog should pop up asking for the root password.
If not, something with KAuth is broken on your system… :wink:

It works fine here (I just tried), and does since as far as I can remember.

Except that kdm didn’t respect most settings (like the theme) in the configuration module in earlier versions, but rather took them from /etc/sysconfig/. This was an openSUSE-specific patch and has been reverted mostly in the mean time. But that password dialog should have appeared anyway, and the same problem did exist when starting it as root as well of course.

It asks for a root password because it has to be done by a process owned by user root.

So it may depend on one’s definition of the meaning of “done by root”, but IMHO both methods point to the fact that it is not in the end-users realm, but root. Logical to me. Because it is about the login screen which is of course independent of any user that might try to login. Imagine, two users who start to chance the login screen theme each hour to their own whish and the chagrin of the other.

Follow up to my post,
I decided to go ahead and test what is described in the MAN pages as I described.

I found that modifying the Plymouth splash actually resulted in displaying a theme <during shutdown> and not during bootup. But, I’m guessing that Plymouth is responsible for displaying the animated progress bar and distro name after Grub and <before> the login screen. It seems that the openSUSE developers made a design decision to deviate from a pure Plymouth configuration.

Reading a few articles on the Internet, it looks like other distros (particularly Debian based) do use Plymouth to set the “wallpaper” for the login screen but openSUSE instead allows the display manager to set instead. This poses a little bit of a complication because every Desktop uses a different display manager and sometimes a different than default display manager can be invoked.

The bottom line is if the display manager sets the login background, then the setting should always be found in the Desktop settings.


You do not describe what you did, but it seemed that you did not create a new intrd and thus your new theme is not available at boot.

BTW this thread is NOT about what happens at boot. The OP has a clear demand in his title: Change the login background.

Absolutely had to create a new initrd in order to apply changes, is required.
Did not post in detail since at least in my mind I satisfied myself that this whole approach (modifying the Plymouth splash) isn’t implemented at the login screen on boot (The OP request).

The steps I implemented are easy to follow and are described in

man plymouth

which leads one to run

plymouth-set-default-theme --help

From that, I determined that you can find all plymouth related packages

zypper se plymouth

Skipping a bit of Internet search I did trying to find pre-packaged plymouth themes and finding only a few generic and many Debian/Ubuntu/Mint themes (which I commented about, with those other distros the background image continues to be managed by plymouth while openSUSE hands off to the display manager), I realized that the generic themes were available as packages in the above zypper search results.

So, installed the plymouth themes,
Then you can install your choice of theme naming the package, eg

plymouth-set-default-theme solar

followed by the following to rebuild the initrd (note you have to again specify the new theme)

plymouth-set-default-them -R solar

Although I also tested the other already available “text” and “detailed” I’m suggesting the solar theme for anyone who wants to play with this so you can see something you can’t miss.
With this solar theme in particular, I found the machine hung on shutdown the first time so I had to acpi shutdown after a few minutes when I was sure it hung. After that, shutdown worked fine without problems.

After you’re finished playing around, you can revert to the default settings removing all your custom settings by

plymouth-set-default-them -r -R

Bottom line and I don’t know if this was the intention of Developers but the graphical display of plymouth is implemented only in part, I see the widgets used to implement the progress bar for instance but nothing else relating to the splash will display during bootup. Leads me to suspect that a custom workaround was implemented somewhere to do this, I doubt it’s default plymouth behavior (but of course is based on pure speculation).


Thanks ]( jetchisel](

That was easy.

Solved - changing background

Posted to wrong thread


Great, more broken stuff , just what i needed :\