Change libllvm for amdgpu

Leap 42.3 comes with libllvm 3.8 for the amdgpu driver. With this version Cities Skylines have some light glitches. As described in this should be solved with newer libllvm versions. Anyone knows a way to replace the libllvm version for amdgpu in Leap 42.3?

A better option is to raise a bug and let the maintainers know and see if the fixes can be (or may already be) backported;

openSUSE:Submitting bug reports - openSUSE

Yes I know. I have already done this, even before Leap 42.3 release:

But I have not the feeling that it will be solved for 42.3 soon, if ever. AFAIK Tumbleweed uses a newer libllvm version. But I don’t want to switch, because that is the only problem which I have with Leap 42.3 at the moment and otherwise I’m happy with it.

You can install llvm4 from OBS, there are a few repositories that offer it for 42.3.

Shouldn’t break anything and some applications actually require the new lib offered by it (f.ex. discord)

Yes I can install some libllvm 4 version from OBS. But this installs in parallel to the existing 3.8 version, which is still used from Mesa. How can I tell Mesa to use the other libllvm version?