Change Hostname via DHCP will NOT uncheck

I have recently setup openSuSE 13.2 on my newest machine -and- in the Network Settings → Hostname/DNS section I can NOT UN-check the Change Hostname via DHCP. Anyone know why -or- what I might possibly have set wrong?? Before it is suggested … I will move to Leap as soon as I can afford a new version of VMware that will run on it.:stuck_out_tongue:


Using wicked or network management?

IF NM then them switch to wicked make the change and switch back to NM

That box should be checkable, always no matter what network management mode you may be using.

Maybe you should check your network device properties, whether DHCP is configured or not?

In any case, I’d recommend running a system update to ensure everything you have installed is latest versions…

zypper up


Both of my machines are Wicked. On the one that will NOT let me change it, the text describing the check box is greyed out, like it is not available… which it isn’t. On the other box, the text is also greyed out but the box is NOT checked.

] Change Hostname via DHCP      **No interface with dhcp**

That is what it looks like on both machines… only one of them has the box checked.


Well, that would mean that DHCP is not even enabled, so there is absolutely no point in changing that setting as it only applies to DHCP obviously…

Enable DHCP and the box should be switchable. But again, it makes no sense to just activate DHCP to be able to change that setting. If DHCP is disabled, it doesn’t matter at all whether this setting is on or off, it is ignored.

Hmmmm… Just when I think I know what I am doing … something like this pops up. That means that I have DHCP enabled on one box and not the other?? I will have to check that out and let you know.


According to what you wrote, I would assume that you have DHCP disabled on both. (you say that the text is greyed out on both)

Again, please note that the actual state of the checkbox is irrelevant if DHCP is disabled.
So just ignore that it is “checked” on one system and not on the other.

Of course, if you actually do want to use DHCP, you should check that it is enabled and then configure this setting to your liking (which should then be possible)… :wink: