Change digital clock from AM/PM to 24 hour

I originally installed 11.1 using the default language selection, English. I then changed to German for my wife, and wanted to change the digital clock display to the 24 hour.In the root display it is in the 24 hour format, in the KDE desktop settings it is also shown in the 24 hour format, but on the user display my wife uses it’s shown in am/pm format. I can’t find any possibility to change the format.

I also installed 11.1 on a usb hard drive to use as my test version for trying new software or settings. I installed in German from the start, and the 24 hour format is shown on all screens.

Anyone have any ideas?


the place to set the clock for 12 vs. 24 hours or am/pm is:

kmenu–>Configure Desktop–>Regional&Language–>tab for Time&Dates and then the Time Format section.

Why in the world they didn’t put this under the Time & Date section of Computer Administration is a complete mystery to me.

Hi Prexy,
You’re right I didn’t think of looking there. I suppose it makes some sense, as you can also change measuring system, paper format, currency and many other things associated to a language or region. Thanks for the tip

You’re welcome :slight_smile:

I notice that when I have changed it to 24-hour format, though the time takes up less space, the widget itself still takes up the same amount of space as before. Half of my reason for switching to 24-hour format was to save space on the bar… Oh well?

In an unrelated note, I love the built-in hardware support of openSUSE, specifically in YaST. I have an IBM SpaceSaver keyboard, on which Shift+Scroll Lock is Num Lock (dual purpose button), and it didn’t work until I went into YaST and chose my keyboard. Now I don’t have to have the external keypad plugged in when I want to turn off the embedded one! :smiley:

Hi, I’m running openSUSE 11.1 just upgraded from 11.0. I cannot find the 12/24 hour options under either the clock’s settings, the configure desktop settings or Yast2’s settings.

All 3 of these allow me to select a time zone though.

On 11.0 a feature that the clock had that I loved was the ability to select multiple timezones for display and when you hover the mouse over the clock a little pop-up appears showing you the current time in all these other time zones.

This feature seems to have disappeared. Is there some way that I can get it back again? I ring people OS all the time and it was a very quick way to determine whether it is a good time to ring or not.



I have upgraded to 11.2 and the extra timezones now work.