Change default "time-until" time for Leave options?

New to OpenSuse. So far, so good. I was a Ubuntu user for a good while but never could get my soundcard working right on my desktop so went back to Win7. I’ve hunted around for the answer to my question but haven’t found it yet. Is there a way to change the default time for the “time-until” countdown timer when one selects to Leave and gets presented the options to reboot, log out, shutdown, etc…? I think the default is 30 seconds but I’d like to change it. Thank you.


I’ve never heard of Leave before. Is it a tool found in Ubuntu? In any case, it would be helpful to know which version of openSUSE and which DE you are using.

I’m running openSUSE 13.1 (Bottle) (x86_64), KDE 4.11.3. The “shutdown/logoff/restart” access button has “Leave” under it so that’s what I’m calling it…is there a proper name for it?

I see. I’m not usually a KDE user, but it makes sense. I’m sure there’s a setting for this, and one of the KDE gurus should be able to help with it.

Dear Splat,

Welcome here.

I hope you see now that a good title, that will attrackt the best knowing people about your subject, is rather crucial when you start a thread for help. Also telling from the first moment which version of openSUSE you use and which desktop is important to get help asap without people spoiling time on areas they can not realy help.

Do you want me to change the title of this thread to something like
“Can I change the time-out on the Leave/Switch-off/Reboot function in KDE?”

You don’t have to wait for the countdown to reach 0 you know.
Just click on Logout or whatever, and it takes effect immediately.

You can also disable that countdown completely in “Configure Desktop”(or Systemsettings)->“Startup and Shutdown”->“Session Management”->“Confirm Logout”.
But be aware that the menu doesn’t even appear then, when you select “Leave” the “Default Leave Option” as configured there will be taken immediately.

I don’t think the countdown interval can be changed, I think the 30 seconds are hardcoded.

HCW, I thought the subject was sufficient, but I leave it to your discretion.

Wolfi323, I saw that setting and that’s not what I wanted. Yes, I know I don’t have to wait for it to reach 0. :slight_smile: I’ll keep hunting around. If I find a way I’ll gladly post it here. Thanks.

Well, as I said I’m not aware of any option to change this interval.
And the link I gave would suggest that it’s not possible either.

So you would have to change the source code and recompile KDE (ksmserver?) yourself.
I had a quick look at the source code, but couldn’t find the place where that interval is defined yet…