Certain websites cannot be accessed

Hello, I’m new to OpenSUSE, but have been using Linux for some years.

I am math teacher and want to access the site webmatematik.dk. I can find the website with nslookup

:~> nslookup webmatematik.dk

Non-authoritative answer:
Name:    webmatematik.dk

and dig:

:~> dig webmatematik.dk

; <<>> DiG 9.11.2 <<>> webmatematik.dk
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10099
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1252
;webmatematik.dk.        IN    A

webmatematik.dk.    30    IN    A

;; Query time: 0 msec
;; WHEN: Tue Aug 14 17:24:26 CEST 2018
;; MSG SIZE  rcvd: 60

So my DNS server is working. Nevertheless, I tried to disable my local DNS server, and use Google DNS at, but I still get the same results in terms of being able to find it via dig and nslookup, but not being able to access it.

In addition, I cannot ping it:

:~> ping webmatematik.dk
PING webmatematik.dk ( 56(84) bytes of data.
--- webmatematik.dk ping statistics ---
690 packets transmitted, 0 received, 100% packet loss, time 1117ms

Furthermore, I have tried to look in /etc/nsswitch.conf, where I changed the “files mdns_minimal [NOTFOUND=return] dns” to “files dns”, but that didn’t solve the issue either.

Any help regarding this problem would be greatly appreciated.

Using a VPN connected to a server in the Netherlands, I was able to access webmatematik.dk using Opera and Vivaldi just now. So I suspect your problem may lie in getting to it from a non E.U. address. Where are you located?

Thank you for the answer. I have actually just tried using a VPN to locate myself in Denmark, and you are right, I am able to access it now - it is some kind of geoblock.