CD Eject Key Not Working

I’ve got a Dell XPS M1530 with openSUSE 11. When I press the CD eject key, it lights up, but that’s about it. I can eject the cd by right clicking the cd icon on the desktop just fine.

I ran xev, but the eject key doesn’t result in any response. All the other laptop keys (volume, play, stop, etc.) do give a response in xev.

Thanks for any help!

Ok, wait a minute. So it doesn’t seem to work if the cd is in the drive before Suse boots up. If I put the cd in while Suse is up and running, everything works fine.

I’ll have to investigate this some more tomorrow.

Ok, so this is weird. I can’t get it to eject with the button at all today. I don’t know what happened last night.

The funny thing is, when I hit the eject button when no cd is in the drive, the drive makes a noise like it is unloading a cd. I think that is a good thing, as that’s what happens in Vista. So suse must know when the button is pressed.

By why does it not do anything when a cd is present?

Ok, I got this figured out. This one is tricky. Turns out, there really is no problem :wink: I will try to explain to the best of my knowledge, in case someone else has this “problem”.

Not being able to take a CD out by pressing the eject button is INTENTIONAL. It is SUPPOSED to be that way. This is sort of a “safety feature” designed to prevent you from taking out a CD when it is still in use. The proper way to take a CD out is to unmount it first (either with ‘umount’ in a terminal, or by going through the file browser and right clicking and selecting ‘unmount’), and then eject the CD.

In fact, if I unmount the CD, I can then press the eject button and the CD pops out. I do not recall having this issue with the other distros I have tried. Of course, each distro can do things the way they want to. But then again, I do not use CDs or DVDs very often, so maybe I just never really tried. I dunno…

Oh, and also, xev does NOT pickup on the eject button being pressed. From what I have read, the eject button does not produce a keycode.