CD/DVD player not recognized

I’ve been trying to play audio CDs in the CD/DVD drive on my machine but I can’t get ANY CD Player software to recognize the drive. However, data CDs are read just fine. If I want to play a CD, I have to use the burner drive which is readily seen by all the audio CD software (KsCD, Kaffeine, etc.). I’ve added myself to the audio, video and cdrom groups but to no avail (I kinda knew it was fruitless to begin with but tried it anyway). I’m running 11.2, 64-bit mode and aside from this minor (but maddening) glitch, I’ve been very impressed with the distro. If someone could point out a solution I’d appreciate it…I don’t want to use the burner for spinnin’ platters. Thanks!

When you have more than one CD drive and you want to use a specific drive just to play CD’s in KDE I might go into Menu > Personnel Settings > Advanced User Settings > Audio CD’s and change the setting from generic cdrom to /dev/sr0 or /dev/sr1 depending on the number of the drive you are trying to use.

Thank You,

Tried your suggestion but to no avail. Even went so far as to try cdrom/cdrom1, dvd/dvd1, and others (all listed devices by the way) which were unsuccessful as well. I dunno…this one has me stumped. The burner still functioned w/o a hitch throughout the “tryouts” but the regular drive just isn’t being recognized for whatever reason. I do appreciate the suggestion though. I’m guessing there’s a config file somewhere that’s got a couple of gremlins in it or isn’t being written to like it should be. I tried your suggestion in both my account and under root.

Audio CD’s are RAW devices and do not seem to get mounted like other devices. The Personnel Settings I mentioned last time is supposed to be for KDE programs. There is another place for CD drive settings which is in XINE. I know of only two ways to get to the setting, one is through the xine-ui settings for media and the second is through Kaffeine/KDE3 (Settings > Xine engine parameters). This might be worth a try. I only have one audio CD’s player and so I can’t play around with this setting. I have pointed everything I can find to /dev/sr0, which was required to play DVD’s and audio CD’s just seem to work also.

Thank You,

Still unable to get the CD/DVD drive to be recognized. I did a hardware probe by the way and that drive is listed as sr0 but it might as well be listed as Mary_Poppins; neither works. As I said before, I do appreciate the help but I guess I’m just gonna have to wait and see if they get it right in 11.3.

Try this:
Start Yast - Security and User Management
Edit your user, check the ‘disk’ group.

Also, since this may reappear in 11.3, please post output of:

ls -l /dev/sr0

and do this:
Insert a CD into the drive, close it, wait 1 minute, open a terminal window and copy and paste output of command below here:

dmesg | tail -20

IMHO this is a solvable problem, we just have to find out where it originates. It may very well be a combo of hardware, that, once detected and dealt with, can be solved.

I checked the “disk” group. As per your request, here’s the info you wanted:

ls -l /dev/sr0
brw-rw----+ 1 root cdrom 11, 0 2010-05-02 08:41 /dev/sr0

dmesg | tail -20
4848.449428] Buffer I/O error on device sr0, logical block 6
4848.449438] Buffer I/O error on device sr0, logical block 7
4848.449449] Buffer I/O error on device sr0, logical block 8
4848.449459] Buffer I/O error on device sr0, logical block 9
4848.451942] sr 0:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
4848.451957] sr 0:0:0:0: [sr0] Sense Key : Illegal Request [current]
4848.451970] sr 0:0:0:0: [sr0] Add. Sense: Illegal mode for this track
4848.451983] end_request: I/O error, dev sr0, sector 0
4848.517720] sr 0:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
4848.517751] sr 0:0:0:0: [sr0] Sense Key : Illegal Request [current]
4848.517776] sr 0:0:0:0: [sr0] Add. Sense: Illegal mode for this track
4848.517804] end_request: I/O error, dev sr0, sector 0
4848.518769] sr 0:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
4848.518797] sr 0:0:0:0: [sr0] Sense Key : Illegal Request [current]
4848.518827] sr 0:0:0:0: [sr0] Add. Sense: Illegal mode for this track
4848.518858] end_request: I/O error, dev sr0, sector 0
4848.520673] sr 0:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
4848.520701] sr 0:0:0:0: [sr0] Sense Key : Illegal Request [current]
4848.520729] sr 0:0:0:0: [sr0] Add. Sense: Illegal mode for this track
4848.520758] end_request: I/O error, dev sr0, sector 0

I have made a new post that concerns optical drive naming in openSUSE and just how it works. I would like for you to read the article and see if it helps you get your CD playing as you wanted.

Multimedia Optical Drive Naming (ie /dev/dvd & /dev/cdrom) Howto in opneSUSE - openSUSE Forums

Thank You,

Very impressive detective work and I should know…I use to be one! My file was set up differently than your example (2 drives of course) so I was a bit confused at first on how to go about changing it:

This file was automatically generated by the /lib/udev/write_cd_rules

program, run by the cd-aliases-generator.rules rules file.

You can modify it, as long as you keep each rule on a single

line, and set the $GENERATED variable.

DVD±RW_GWA4164B (pci-0000:00:1f.1-scsi-0:0:1:0)

SUBSYSTEM==“block”, ENV{ID_CDROM}=="?", ENV{ID_PATH}==“pci-0000:00:1f.1-scsi-0:0:1:0”, SYMLINK+=“cdrom1”, ENV{GENERATED}=“1”
", ENV{ID_PATH}==“pci-0000:00:1f.1-scsi-0:0:1:0”, SYMLINK+=“cdrw1”, ENV{GENERATED}=“1”
SUBSYSTEM==“block”, ENV{ID_CDROM}=="?", ENV{ID_PATH}==“pci-0000:00:1f.1-scsi-0:0:1:0”, SYMLINK+=“dvd1”, ENV{GENERATED}=“1”
", ENV{ID_PATH}==“pci-0000:00:1f.1-scsi-0:0:1:0”, SYMLINK+=“dvdrw1”, ENV{GENERATED}=“1”

DVD-ROM_DDU1615 (pci-0000:00:1f.1-scsi-0:0:0:0)

SUBSYSTEM==“block”, ENV{ID_CDROM}=="?", ENV{ID_PATH}==“pci-0000:00:1f.1-scsi-0:0:0:0”, SYMLINK+=“cdrom”, ENV{GENERATED}=“1”
", ENV{ID_PATH}==“pci-0000:00:1f.1-scsi-0:0:0:0”, SYMLINK+=“dvd”, ENV{GENERATED}=“1”

Then I noticed the top four device names had nothing after them (the number “1” to be exact) while the bottom two devices did have the “1” after them. I reversed this to what you now see above and everything works as it should. The CD/DVD drive now plays normally and the DVD-RW still writes as it always had but now won’t read audio or data discs but that’s fine with me…I never use it anyway except to burn with. I really appreciate the work you put into this and I hope the folks at SuSE are taking notes as I’m sure this has happened to others as well. Thanks again!

Yeah! Happy to hear this helped you get to the setup that you wanted. You could always give the other thread a high rating, if indeed you found it useful. I would appreciate that and any things that could be added to the thread. Such things as how you found your setup file at first, just what that was doing to you and any final solution you used. All of this will then help the next user find their solution as well. I have found that if you go to the trouble to write it out, it not only helps the next guy, but it helps you understand the subject even better yourself. You have a good day and thanks for taking the time to let us know of your success.

Thank You,