Careful with the latest Tumbleweed update 20190401- new kernel default base is outdated

Be careful when updating your Tumbleweed, the latest snapshot date 2019-04-01 has an old kernel-default-base package, version 5.0.3 instead of 5.0.5 like all the other kernel packages. Virtualbox is also not updated and will be broken by this update.

I checked the Tumbleweed repo and it is indeed only the old version available.

Why are you installing kernel-default-base? That’s not something that would normally be installed, so I doubt that this will be a problem for most users.

It gets pulled in when you do a zypper dup. I did not had that package before. I wouldn‘t be so sure that only a small number of users will be affected.

No, it doesn’t:

knurpht@Knurpht-HP:~> cat /etc/os-release 
NAME="openSUSE Tumbleweed"
# VERSION="20190401"
ID_LIKE="opensuse suse"
PRETTY_NAME="openSUSE Tumbleweed"

knurpht@Knurpht-HP:~> zypper se kernel-default
Gegevens van opslagruimte laden...
Lezen van geïnstalleerde pakketten...

S  | Naam                 | Samenvatting                                            | Type  
i+ | kernel-default       | The Standard Kernel                                     | pakket
   | kernel-default-base  | The Standard Kernel - base modules                      | pakket
i  | kernel-default-devel | Development files necessary for building kernel modules | pakket

so something else must have happened

Only when there is something odd about your software that pulls it in as a dependency. You may have a driver with a dependency on an older kernel version.

I thought kernel-default and kernel-default-base were mutually exclusive? Just install kernel-default.

As root, run /sbin/vboxconfig to fix.

I will make a wild guess. The is possibly a side effect of the virtualbox issue. Since virtualbox was not updated, it probably has a dependency on an older kernel. But if that older kernel was removed, they zypper pulls in kernel-base for that older kernel version to satisfy the dependency.

FWIW: I had to run /sbin/vboxconfig as root to make VirtualBox work after the dup to the 20190401 snapshot, as xorbe suggests, but the dup did not pull in kernel-default-base.

Speaking of VirtualBox, I had to change my display adapter to “VboxVGA” to get resizing working. This is probably due to the stale virtualbox pacakages, and that the guest tools don’t compile against the current kernel, etc. It’s working mostly, but the graphics are slower, and I think vbox mounts are busted.

Reason for the installation of kernel-default-base was in my case the ‘outdated’ virtualbox.

That can’t be, because it didn’t install kernel-default-base on my system, and I have VirtualBox installed.

I locked the kernel default-base, so it can not be installed, zypper dup then gave me the option to break virtualbox or unlock the kernel-default-base and nothing else. If you conclude that it has nothing to do with virtualbox then this is up to you.

I had the same problem and only /sbin/vboxconfig solved it.
What is even very strange for me is: When I look in the version 6.0.4_k5.0.5_1 is shown.
However, when I tell to install this version, only the version 5.0.3 is installed.

My repositories are:

| Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung

1 | | KDE:Extra | Ja | (r ) Ja | Ja
2 | | Packman Repository | Ja | (r ) Ja | Ja
3 | | libdvdcss repository | Ja | (r ) Ja | Ja
4 | openSUSE-20180803-0 | openSUSE-20180803-0 | Ja | (r ) Ja | Ja
5 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ----
6 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja
7 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ----
8 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja


I have update Tumbleweed and solved the VirtualBox issue with /sbin/vboxconfig.
However, you might still have a problem with VirtualBox Guest Additions which is not working out of the box on Tumbleweed.
So, try to download and install it separately. I have no issue using it now.

Yes, this is the problem. The package name says k5.0.5 (kernel) but the files installed are only for kernel 5.0.3: