Can't update because of ibus-gtk-32bit

Hello, I can’t update since 2 days…

Checking for file conflicts: …[done]
( 1/241) Removing ibus-gtk-32bit-1.5.17-1.2.x86_64 …[error]
Removal of (64204)ibus-gtk-32bit-1.5.17-1.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: /usr/bin/gtk-query-immodules-2.0: error while loading shared libraries: cannot open shared object file: No such file or directory
error: %preun(ibus-gtk-32bit-1.5.17-1.2.x86_64) scriptlet failed, exit status 127
error: ibus-gtk-32bit-1.5.17-1.2.x86_64: erase failed

Abort, retry, ignore? [a/r/i] (a):

What can I do now ?
thanks you

Apparently gtk2-tools-32bit hasn’t been updated in the repo.
That’s not the only problem with TW 32bit at the moment… (see )

Seems like something went wrong with publishing the (32bit) snapshot, at least some of the packages are outdated and haven’t been updated which causes dependency problems.

I suppose it will be fixed soon (with the next snapshot at the latest), for now I suppose you could just uninstall ibus-gtk-32bit, it’s only necessary to use ibus in 32bit GTK applications (I think).

I had a similar problem yesterday, and managed to solve it by re-installing the offending library (in your case it would be libpixman, I believe) and then retrying to update ibus-gtk.

Although, I just had a look and gtk2-tools-32bit has been updated and the package in the repo doesn’t require anymore.

Just to be sure: you are using “zypper dup”, right?
That’s the only recommended (and supported) way to update Tumbleweed.

libpixman-1-0-32bit to be exact.
Yes, that should “fix” the problem as well.

But should not be necessary, as the latest gtk2-tools-32bit package (and the /usr/bin/gtk-query-immodules-2.0 it contains) does not require it anymore.
It may be a problem with the package install/uninstall order though…

OK thanks for getting me on the right way, I installed :


and it works now, my
“sudo zypper dup” is going fine !

Thanks you very much

Nice it is solved.

Please next time when posting computer text as in the first post here, use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

Including the prompts and the command then will make such questions as wolfie323 did

Just to be sure: you are using “zypper dup”, right?


OK, sorry, I will do it next time.:wink:

thanks all