Can't turn off autologin, unable to login with password

Hi All - I have an interesting issue. On initial install of my Tumbleweed system about 2 years ago; I set “autologin” to “yes”. Great.

The Problem: When I “logout”, I am unable to login again. I have to reboot my system and let “autologin” log me back in. If I try and login, I get a “invalid password” error.

But I am 100% certain that is not the case - as I can lock my screen, and unlock with the same password, I can switch to a TTY shell and login at the shell prompt with my username/password. It only happens at the Graphical login screen.

I tried turning “autologin” off … which effectively locked me out of the system as I could no longer log in at the SDDM greeter. I had to reboot to an old snapshot and revert back to a state prior to turning off autologin.

I did a fresh install of TW on another laptop, but chose to not set “autologin”. At the SDDM greeter, I can successfully login with my username/password.

I’m trying to switch from X11 to Wayland … but I can only seem to do that via the SDDM login greeter screen … which I can’t get to without locking myself out from logging in.

Any pointers / hints / suggestions on where to start digging to resolve? I’m fine going back to manual login as long as I can … actually … login. :slight_smile:

Tumbleweed 20240416-2856.1
KDE/Plasma 6
sddm 0.21.0-1.2
sddm-kcm6 6.0.3-1.1
sddm-greeter-qt6 0.21.0-1.2

Happy to provide any other relevant system information. Much appreciated !!

Maybe try resetting your password, just to be sure that that’s not the issue?

From a terminal window, you can just run passwd. Actually, it’ll prompt for the old password, so if that works, that’ll tell us that the issue is somewhere else and not the password. If it doesn’t accept it, then you’ll need to run passwd as root in order to change it without knowing the old password.

maybe a startup script triggers faillock state ?

Can you log in on text console?

Thank you for the response. I’m quite certain it’s not my password. My lock screen unlocks with the password, a terminal shell login works correctly with the password, and network loging (SSH with password auth) works with the password.

1 Like

Thank you for the response. I’m quite certain it’s not my password. My lock screen unlocks with the password, a terminal shell login (text console) works correctly with the password, and network login (SSH with password auth) works with the password.

Thank you for the reply - any idea where I might poke around to check that? It’s definitely not something (intentionally/knowingly) setup …

maybe a false keyboard layout at the login screen, can you see the letters you are typing?

I experimented with this yesterday. This was in a virtual machine running Krypton (Tumbleweed with the additional KDE repos).

I had been using Wayland. When I turned on auto-login, then the next login was to X11. I logged out, and then logged into Wayland (manually). On the next boot, again auto-login took me to X11. It seems that it only does X11.

I have tried this before when using GDM or LightDM for the login. And with those it does work the way that expect. But apparently SDDM behave differently.

I have exactly the same problem. If the system crashes I can unlock it with the password just fine but if it logs out it can’t log back in with the password. I have KDE and the default login manager.

The screenlocker for Plasma5/6 and sddm have absolutely nothing to do with each other, even though they may visually be similar.

sddm isn’t “part” of KDE/Plasma, but a third party piece of software that isn’t actually integrated, like gdm is with GNOME.

Please file a bug against sddm at bugzilla,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.