Can't see controls in firefox


I cannot see any control in firefox.

I cant’ see sidebars at right
I can’ see radiobuttons
can’t see checkboes

And so on.

In applications I cam see it, and on others browsers I see them (Opera, Chromium)

Do you know how can I solve this ?

Thanks in advance for any feddback


There’s not really enough information to help. You probably messed up some of the firefox settings.

You can completely nuke your firefox setup with:

rm -rf .mozilla

Then, when you next run firefox, you will get a fresh start. Be warned however, that this might also nuke settings for other mozzilla software such as “seamonkey”.

Perhaps safer would be to run firefox with:

firefox -P

Do that at a command line in a terminal session that you open from your desktop.

That should allow you to create a new profile. Once you get things working in the new profile, you can possibly copy your bookmarks and maybe your cookies, from the old profile to the new.

there wore some similar issues reported with noveau on plasma 5
using nvidia’s driver (bumblebee on newer laptops) fixes things

I think the reason for this is hardware acceleration, it use to be off om unix systems, mozilla seams to have turned it on, maybe disabling it in Firefox settings might fix things


rm -rf .mozilla
mozilla -P

didn’t work. Maybe I should see my nvidia setting. I’m lost with this issue

I have exactly the same problem with Firefox for several months. The scroll bar and selection windows inside the Firefox window become invisible - but if you know where they are, you can still scroll or enter data. The strange thing is that it seems random - occasionally the problem goes away for no apparent reason.

I’m running an up-to-date version of Leap 42.2 with Nouveau and the latest Firefox. The graphics card is a GE Force 9400 GT. Perhaps I should try Nvidia.

Very frustrating. (Konqueror does not have this problem).

Well I just tried installing Nvidia on a spare copy of 42.2. I now remember why I didn’t install it before!!

I get a problem when I return from “suspend”. All the name boxes under desktop icons are corrupted and the only way to fix it is to reboot. This doesn’t happen with Nouveau.

I see that every application on Suse Leap 32.2 works, except Firefox. (I can see them from opera, chromium, konqueror, and any other application)

My (temporal) solution is not use Firefox, but of course there must be another solution. (I think)


It looks as if Leap 42.1 works ok with the latest version of Firefox and Nvidia video drivers (V 52.1.1).

I am going to use 42.1 for a while.

how did you install the driver?
what driver do you use G03 G04 or G02?
is that a laptop or a desktop?
the driver for 42.1 is the same for 42.2 if it works on one it should work on the other


I installed G03 with Yast as it is the driver for “GEForce 8xxx and newer GPUs”. Both my 42.2 and 42.1 are running on the same desktop PC.

I’ve found that there is a bugzilla report (No 1036994) relating to this problem, so I’ve added a few comments to that.

I have the same problem with opensuse 42.1. Sometiomes controls did appeared and remained for several days, but now they are gone again. For me it’s not easy to give up firefox, as I use thunderbird as my standard mail program and controls dissapear in thunderbird too. Curiously sliders dissapeared in Konsole too, but they are visible again now.

Reinstalling KDE, Firefox, nvidia, nouveau, removeing .firefox, etc. won’t help. I tried also with gnome instaed of KDE and to switch “splash=verbose” in grub2, and afterwords controls appeared for some da time, but I couldn’t find any proper correlation with what I tried.

I suspect you may need to run the 04 version along with the other g04 files. I am with a 1050 card. I suspect that the 02 and 03 drivers are there more for specific cards but must admit I am not clear on this subject. I’m not sure if anyone around on here is.


the G02 driver is for very old cards from the 6xxx up to 9xxx series
the G03 is for the older hundred series 1xx up to 6xx
the G04 is for the latest chipsets 6xx up to the new titan x 10xx
as with most nvidia drivers there is some overlap ie you can use G03 and G04 on the 4xx, the G03 might run on 9800 etc
in general both yast and zypper install the appropriate driver for your card
after adding the nvidia repo in zypper do

zypper inr

to get the driver for your hardware, in yast after adding the repo start software management and the driver for your card will be preselected for install

I have a workaround for a problem I mentioned above in this thread, which is that with 42.2 (KDE, Nvidia, GEForce940GT, desktop folder view) when resuming from “suspend”, all the desktop icon names are corrupted. If you have this problem, try the following -

Right click on desktop, select “configure desktop” and if you are using “Folder View”, change it to Desktop and click on “apply”. This removes all the icons and text.

Then reselect “Folder View” to retrieve the icons, which (in my case) are now ok. They should also be ok if Suspend and Resume are used again - but rebooting will bring back the same problem.

Simply moving an icon with the mouse will fix the name text for that icon but the above process fixes them all at the same time.