Can't run shell scripts

I’ve recently installed OpenSUSE for the first time and trying to get everything working. Right now, I’m trying to install an Nvidia driver with a filename that looks like this:

NVIDIA-Linux-x86_64-340.24.run

When I double-click, I get the following:

> There is no specialized application for files of the type shell script (application/x-shellscript).
The file can be opened in a more generic application as file type plain text document (text/plain), or you can try to install a specialized application for file type shell script (application/x-shellscript).
Do you want to try to install a specialized application?

If I click “Yes”, I get this:

> The software to install could not be found in the currently enabled software repositories.It may be located in other repositories.
See http://help.opensuse.org/ksuseinstall for details.
Do you want to configure your repositories?

…and now I’m stymied. Any suggestions? I read a similar post in which the problem was a Java file with a .sh extension (I think), but I’m not sure whether or not this is the same issue.

Many thanks in advance for any assistance!

Hi
Either precede with sh or change the permissions to make it executable;


sh NVIDIA-Linux-x86_64-340.24.run
or
chmod 0755 NVIDIA-Linux-x86_64-340.24.run
./NVIDIA-Linux-x86_64-340.24.run

Also you do know you can install from Yast. If you install manually like you are trying to you will need to reinstall after any kernel update. If you use Yast you will not need to reinstall.

Tell us your nvidia card/chip and someone can give you exact instructions or

go to the one clcik

https://en.opensuse.org/SDB:NVIDIA_drivers

Thank you all very much!

Some progress: I managed to get started with both the 1-click and via YaST, but both times I’m unable to download the driver. Just now I tried installing via Konsole, and this is what was returned:

Retrieving: nvidia-gfxG03-kmp-desktop-331.79_k3.11.6_4-27.1.x86_64.rpm …[error]
File ‘./x86_64/nvidia-gfxG03-kmp-desktop-331.79_k3.11.6_4-27.1.x86_64.rpm’ not found on medium ‘http://download.nvidia.com/opensuse/13.1/

Am I understanding this correctly, that the file being sought is not in fact present in the Nvidia repository? Or is something here my fault?

Very many thanks again.

Please, when do not only show the (error) messages you get on the Konsole, but also what you did: the command. How can we check if you made an error when we can not see what you did? And copy/paste that please betwen CODE tags. You get CODE tags by clicking on the # button in the tool bar of the post editor.

Yes, the driver packages in the repo have been updated to 331.89 today, probably just when you tried to install them.
It could be of course that you have auto-refresh disabled for the nvidia repo, so YaST/zypper will not recognize automatically that there are newer packages (and the old ones are not there any more).

Run this to install the driver:

sudo zypper ref
sudo zypper in x11-video-nvidiaG03 nvidia-gfxG03-kmp-desktop nvidia-gfxG03-uvm-kmp-desktop nvidia-computeG03 nvidia-glG03

(normally you shouldn’t have to specify all 5 packages, that’s just to be sure…)

And check with “zypper lr -d” or YaST->Software Repositories whether auto-refresh is on or off, and enable it if necessary.

PS: there does seem to be a general problem with the nvidia repo atm (again).
They updated the driver packages, but the repodata is still from June 10th.

So you have to wait until the repodata has been updated, too.

If you cannot wait, you might download the driver packages directly here:
ftp://download.nvidia.com/opensuse/13.1

Then install them with “rpm -i filename1 filename2 …” or “zypper in filename1 filename2 …”.

You need those 5 packages that I mentioned earlier:
x11-video-nvidiaG03 nvidia-gfxG03-kmp-desktop nvidia-gfxG03-uvm-kmp-desktop nvidia-computeG03 nvidia-glG03