Can't run gambas in KDE Leap 15.2

Hi, gambas 3 was installed from with yast, when tried to use it never opens de ide, so run


in the terminal and show this:

gbx3: unable to find startup file


Already install all gambas3 pattern packages in yast and run

zypper update

command in the terminal as root, and still no works gambas.

Could anyone help me? :slight_smile:

The gambas IDE is gambas3-ide, gbx3 is the runtime component, so would expect a file to be used…

when run “gambas3” in the terminal show: “gbx3: unable to find startup file”, how can install the file expected to be used?:sarcastic:

Use the help option :wink:

 gbx3 --help

Execute a Gambas project or evaluate a Gambas expression (-e option).

Usage: gbx3 [options] <project file>] -- <arguments>]
       gbx3 -e <expression>

  -g               enter debugging mode
  -s <class>       override startup class
  -p <path>        activate profiling and debugging mode
  -k               do not unload shared libraries
  -H --httpd       run through an embedded http server
  -j               disable just-in-time compiler
  -t --trace       dump the position of each executed line of code
  -e               evaluate an expression
  -V --version     display version
  -L --license     display license
  -h --help        display this help

You should start the ide (as in run gambas3-ide, or start via the desktop icon), then you can create a new project etc.

If anyone still experiencing the error “gbx3: unable to find startup file” or any of the missing component mentioned when running “gambas3.gambas” please see my explanation here: Can't execute gambas3 - #4 by jasongodev

Basically you need to install the missing component. In my case it is “gambas3-gb-jit”.