Can't remove systemdboot from my previous install of nixos and can't boot into opensuse

Hello, I have made a mistake and installed nixos which killed my windows partition and abducted my bootloader. Because grub don’t run, after installing opensuse my computer got bricked. Bootloader only shows nixos and I don’t know what to do. I tried to rescue my pc with opensuse usb stick and tried to do the mount and chroot but it says my ssd is busy and can’t umount it because it says it’s not mounted. Does anyone know a way to nuke my efi?

I’m only guessing here, because I don’t have much information on your system.

Boot that USB stick to get to a command line.

Then use the command:


to list the boot entries.

To delete a boot entry, use something like:

efibootmgr -b 0001 -B

That should delete entry 0001.

Some of the boot entries might be for BIOS things (such as booting from the network). Don’t try deleting those.

If possible, mount the EFI partition of your internal drive. Then cd to “/EFI/BOOT” in that EFI partition. That might be “/EFI/Boot” or some other capitalization. Remove any files in that directory. That should nuke the EFI booting, but allow a fresh install to recreate.

I don’t think I have ever tried “nixos”, so I’m not sure what you are dealing with.

I deleted an problematic entry, at 0000 which was labeld manjaro, that entry is from the first time I installed linux on my pc which was roughly 5 years ago. It tries to find a non existent grub efi file. I think that might be one of the problems. Unfortunately when I reboot my pc it just comes back…

Which one is the efi partition? If it’s my ssds boot partition, it can’t be mounted.

Ok deleted the manjaro entry from bios interface. Now I’m going to update the system and hope for the best.

Nope, manjaro wasn’t our culprit. Still the same problem. Gonna try efibootmgr again for good measure.

Edit, nope still hopeless. Gotta check the answers tomorrow, gnight!

Ok, I actually couldn’t sleep, on the bright side, I solved the issue! So I completely forgot I had to add my boot partition to fstab. Did that, mounted, obligate anything nix and systemd related emptied efi/BOOT updated the system from usb and boom it’s there! Now the only problem I have is rescuing the windows efi. The os is there but i can’t reach it via booting.