Cant poweroff or reboot Tumbleweed.

Installed Tumbleweed june30. I kept it up-to-date whenever updates were available. Recently I noted that on reboot or logoff, using the Gnome interface,
I wait for and do not get the poweroff/reboot occurring. Hitting escape shows me a console message of “awaiting reboot”, or some similar message.

I noted and will reconfirm, that if I do not use the GUI interface, but remain in xorg terminal mode, and then request a poweroff/reboot, Tumbleweed functions as expected.

Any clues where to look? Should I just reinstall TWD? I am using xorg and GNOME.

Same problem occurs with regular or hypervisor Tumbleweed boot folllowing gnome use.

The problem is that the keyboard and monitor and mouse are locked up. My only recourse is to hold the poweroff switch for a few seconds until the motherboard bios shuts the computer down. Then I repower.
I looked at the journal, but it seems to say Everything is OK.

So now, I am trying a work around. I log in in terminal mode, and run startx. When I leave gnome with my logout, I am back to terminal mode. And I hope a normal poweroff or reboot does what it should.

And yes, I will check out the third link.

Thank you for the three links

Yours from Montreal

What happens if you close all applications and log out of gnome, and then try to shutdown via gdm (the login manager)?

I tried it that way too, and it still locks up. BUT
I have a partial workaround.**
I log in with console (ctl-alt-F4 ) and issue my startx. I am launched into Gnome. When I log out from Gnome, I am returned to terminal mode and then I issue the poweroff or reboot, and it works.

I started to peruse the third link you provided and I will see what things I can do to discover the “block / wait for some completion” to occur. when in Gnome. I generally do a fresh installation every six months, but if there is a rainy day before December, I will do the fresh installation somewhat sooner.

If you find some clues for me, I do check this forum every day.

Again, thank you for the follow-up.

Out of curiosity, I tried shutting down from gnome and it worked (TW 20190829).

Have you tried using lightdm (install and switch with Yast2 -> Alternatives)?

Are you using proprietary video card drivers?

Hi Ravi.
Bad news and good news.
The good news is that yesterday 31Aug, a zypper dup installed almost 250+ updates. On reboot and with testing, the indefinite (infinite) wait for reboot to occur has disappeared. The system is back to normal.

The bad news… I/we will never know what caused the problem.

Thank you for your help. It was much appreciated.