can't play dvd with gstreamer, can't play .avi with xine

I changed the backend of phonon from xine to gstreamer because I wasn’t able to play .avi files with xine. I installed libxine1, and libxine1-codecs, but Kaffeine, Dragon Player and Gwenview crashed when trying to play an avi file. After changing the backend I was able to play .avi files, but now I can’t play DVD’s, which I’m able to do switching back to the xine backend.

If someone could tell me how to play dvd’s with the gstreamer backend I would be very thankful

Follow this
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Do this last

P.S. If you are not using 11.2 let me know

It might help if you had libdvdcss installed, if it isn’t already. If it’s already installed have you got all the gstreamer plugins installed? I think there are a whole bunch of them with names like ‘gstreamer-plugins-good’, ‘gstreamer-plugins-bad’, ‘gstreamer-plugins-ugly’ etc. If not give that a try and see what happens.

Hope this helps.



[EDIT: ****, caf4926 beat me to it!]


I tried your suggestion, and in the last step it updated a lot of packages, but I still have the same problem. I can play DVD’s with xine, and avi files with gstreamer but I can’t play dvd’s with gstreamer or avi files with xine.

What I’m doint right now is to play dvd’s with vlc and use the gstreamer for everything else but I would prefer to also play the dvd’s with kaffeine.

If you can play DVDs with xine, you should be able to do the same with kaffeine as long as the xine backend/engine is selected in kaffeine. Is this backend no longer controllable/selectable in the KDE4 kaffeine ? (I know it was controllable in the KDE3 kaffeine).

I think KDE4 kaffeine will take the default desktop setting. So if you are using KDE4, you need to go to Configure Desktop > General > Multimedia > Backend and select xine or gstreamer as the appropriate backend to get the behaviour in kaffeine that you want.

Note that changing that setting will also be applied to other application in KDE that use the default desktop system settings.

I can change the engine in system settings, the problem is that if I choose gstreamer, then I can’t play dvd’s, and if I choose xine, then it crashes when it tries to play avi files. It’s cumbersome to change the engine depending on the file, that’s why I would like to solve any of this 2 issues.

In any case right now I’m using smplayer to play dvd’s and avi files and I have left the gstreamer engine so that I can watch avi files in gwenview and dolphin.

You might want to try kaffeine too
Not sure what the fascination with gstreamer is. I only use xine

I have already tried kaffeine, but it will use whatever I told phonon to use, so, when using xine it won’t play avi files, and when using gstreamer it won’t play dvd’s :frowning:

I would like to understand what codec is in these avi files you are trying to play. The packman packaged xine (with no videolan packaged apps) plays fine various avi files (with different codecs) on my PC, hence I confess I believe you have something set up wrong on your PC.

Note I alway have only 4 and only 4 (no other) repositories permanently enabled (OSS, Non-OSS, Update and Packman) and I have had it that way since the 1st install of openSUSE. Adding others IMHO only leads to problems that are difficult for new and average users to solve. So do NOT add others. Do NOT. I repeat, do NOT add others. …

what is the output of:

zypper lr -d

Hopefully ONLY 4 repositories show up when you type that. If you have added others, then that can cause problems which are very difficult to solve.

I recommend you download mediainfo from Packman, and use that to determine what codec is in the avi file. Without that knowledge it is very difficult to guess what could be wrong with your PC setup.