Can't mount usb hard drive

Problem mounting Seagate Backup Plus usb disk.

This device will not mount on one of my computers.

Laptop with opensuse 15.1 No problem
Laptop with opensuse 10.3(!) No problem
Desktop with Windows XP No problem
Laptop with Windows 7 No problem
Desktop with opensuse 13.1 Big problem, see below

I started with this disk by removing the factory partitions, and
replacing by a single ext4 partition. After problems started,
I removed this, and made a single 100Mb FAT partition; the
results below refer to this setup. Partitioning was done with
gparted on the opensuse 15.1 laptop.

On plugging the disk into the 13.1 desktop, nothing happens.
Looking at the device notifier, I see “No devices available”.

Running dmesg, I see

[18915.924769] usb 2-1.7: new high-speed USB device number 50 using ehci-pci
[18916.070336] usb 2-1.7: New USB device found, idVendor=0bc2, idProduct=ab24
[18916.070342] usb 2-1.7: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[18916.070345] usb 2-1.7: Product: BUP Slim WH
[18916.070347] usb 2-1.7: Manufacturer: Seagate
[18916.070349] usb 2-1.7: SerialNumber: NA9NHJ4C

So the system sees the disk. Note that no device identifier is shown.

fdisk -l shows the expected partitions for sda, the internal hard
disk, but no other entries. Looking in /dev there is no /dev/sdb

So, you might think that automounting is totally screwed up on this computer.
However, usb memory sticks, and an old NexStar external drive work correctly.

Looks like the specific combination of this computer and the Seagate drive
cause /dev/sdb to not be created, leading to a failure to mount.

Any suggestions?

If you are looking to have it auto mounted not at boot, but at random times per your preference, then ensure there is no entry for the USB hard drive in /etc/fstab.

I like add to this.
When you do have an entry in /etc/fstab, you can put thare all options, etc. to make a “manual” mount easier. But you should have “noauto” as an option to prevent the system to try to mount it at boot. And maybe a “nofail” to prevent hanging when a mount is tried when the device is not present.

Thanks for the suggestions, but /etc/fstab is not the problem.
There is no entry for this disk in that file.

The problem seems to be that the device file /dev/sdb never gets created
when the disk is plugged in; with all other removable media, it is created on plugin.

Seems like a misconfiguration somewhere. What software package is responsible for
creating /dev/sdb dynamically when needed, and where is its configuration file?

Maybe something funny about the device or it’s format. I assume it works in in the other OS…

Tried other USB ports???

13.1 is very very old is the hardware equally old?

As mentioned in my original post, it works on a truly ancient computer with 10.3!
Also works on oldish computer with 15.1.
Same behaviour on all usb ports.

Further info:
lsusb shows the disk to be present, lsblk does not.

I just plugged in an external USB drive. And then I looked at output from “dmesg”.

I am seeing:

[38697.965223] usb 1-1.1: new high-speed USB device number 4 using ehci-pci
[38698.077250] usb 1-1.1: language id specifier not provided by device, defaulting to English
[38698.078373] usb 1-1.1: New USB device found, idVendor=0bc2, idProduct=0503
[38698.078377] usb 1-1.1: New USB device strings: Mfr=42, Product=57, SerialNumber=83
[38698.078379] usb 1-1.1: Product: Seagate External Drive
[38698.078381] usb 1-1.1: Manufacturer: Jabil Circuit
[38698.078382] usb 1-1.1: SerialNumber:  SG062003756
[38698.136607] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[38698.137053] scsi host6: usb-storage 1-1.1:1.0
[38698.137115] usbcore: registered new interface driver usb-storage
[38698.140351] usbcore: registered new interface driver uas
[38699.170788] scsi 6:0:0:0: Direct-Access     Seagate  External Drive        PQ: 0 ANSI: 0
[38699.170992] sd 6:0:0:0: Attached scsi generic sg4 type 0
[38699.172217] sd 6:0:0:0: [sdd] 488397168 512-byte logical blocks: (250 GB/233 GiB)
[38699.173091] sd 6:0:0:0: [sdd] Write Protect is off
[38699.173093] sd 6:0:0:0: [sdd] Mode Sense: 27 00 00 00
[38699.174095] sd 6:0:0:0: [sdd] No Caching mode page found
[38699.174096] sd 6:0:0:0: [sdd] Assuming drive cache: write through

You appear to only be seeing the equivalent of the first few of those lines. You are not seeing anything that identifies it as a drive (storage device).

If, by chance, you are plugging it into a USB3 port, maybe try with a USB2 port instead.

I did have a situation here where I used a SATA USB3 docking station. The computer recognized the docking station but it did not recognize the disk. When I switched to an USB2 port, it worked. But it works fine with a USB3 port on a different computer. Some of the early USB3 support (as on older computers) was a bit flaky.

It’s a kernel problem! I had been running kernel-desktop. I booted kernel-vanilla
instead, and now it works (both on usb2 and usb3 ports). Kernel-default also has the problem.

So I guess I will switch to kernel-vanilla. What will I be missing by using
the vanilla version?

Not much on a supported OS you miss updates but since there are no updates…

Sorry, I didn’t search the forum well enough before posting.

An explanation, and a better fix are given by Gerry Makaro here: