Can't login to gnome-shell

Hi everyone.
I can’t login to gnome shell after installed Nvidia driver for 64bit Linux.previously my Opensuse was broken,once GDM was started,it said “oh on,something has gone wrong…”,but startx worked fine.I couldn’t detect what was wrong so I fresh installed OpenSUSE 12.3,left /var and /home not formatted.When I first login newly
installed system the normal account can succeeded to login,but after nvidia driver was manually installed I can’t get my normal account login gnome shell anymore,
every time I try it just returns to login screen.However root can login gnome shell and other sessions,also the normal can login to iceWM or KDE.So I try to delete all
hidden files under my home folder,but it doesn’t make sense. I don’t know what’s wrong with my opensuse,hope my bad English won’t trouble you,and any help will be appreciated.

Did you already do this ?

Thank you for replaying.I tried this,but it didn’t work.I even couldn’t see the mouse pointer,and it directly returned to login screen.

Did you try “advanced” menu in boot screen and boot in “safe” mode ?

It was all the same.Finally I gave up,and reinstalled the system.Now it runs well.Maybe sometimes there are some problems difficult to solve,anyway,thanks the same.Should I mark this thread solved?