Can't install Zoom correctly

Hi all,

I just did a fresh install of openSUSE Tumbleweed. I need to install Zoom for class, but after I’ve downloaded the .rpm file from Zoom’s website, and I right-click on it to open and install with YaST, YaST gets about 53% finished, then I get this message:

Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.

Caller: /usr/share/YaST2/clients/sw_single.rb:153:in `CheckWhichPackages'

Details: undefined method `EnsureSourceInit' for #<Yast::PackageClass:0x000055f15bca2e00 @my_textdomain="base"], @last_op_canceled=false, @installed_packages=], @removed_packages=]>

Then YaST crashes. I’m new to openSUSE, and I also tried Flatpak from here, but it doesn’t seem to be working either: When I click to install Zoom, Flatpak doesn’t show any indication of working to install, but the button “install” merely becomes “cancel”…and nothing happens.

If anyone else has had similar experience and knows of a work-around or can diagnose the issue, that would be just swell. Thanks!

my zoom works in tumbleweed - this is how I installed it.

sudo zypper in zoom

Thanks for your time. Unfortunately, when I ran your line of code, I got this message:

Loading repository data...
Reading installed packages...
'zoom' not found in package names. Trying capabilities.
No provider of 'zoom' found.
Resolving package dependencies...
Nothing to do.

Zoom still won’t install for some reason.

I also tried this based on this website:

sudo rpm -i /home/user/Downloads/zoom_openSUSE_x86_64.rpm

And got this:

warning: /home/user/Downloads/zoom_openSUSE_x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 61a7c71d: NOKEY
error: Failed dependencies: is needed by zoom-
    ibus is needed by zoom-
    ibus-m17n is needed by zoom-

Use zypper.
As root:

zypper in /home/user/Downloads/zoom_openSUSE_x86_64.rpm

That should install all needed requirements.

Wow thanks, it worked! For anyone else having a similar problem, I just needed to “ignore” with:

zoom- (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]

Abort, retry, ignore? [a/r/i] (a): i

Known, because you have only downloaded the package and not the key…

I have the same trouble with installing all rpm packages via Yast2, for example, Chrome. zypper - ok

Found the related bug -