Can't get Thunderbird or Evolution to connect to my mail account

HI All,
Long time Linux user (on various distros, but mostly Mint) but this is my first venture into openSuse.
The first thing I do when trying a new distro is to set up Thunderbird, a process that normally takes about a minute. When I tried it in openSuse it correctly probed my provider and offered the correct setup, which I accepted. However it then displayed an error message saying “Unable to log in at server. Probably wrong configuration, username or password”. I have quadruple checked all of these things several times, and I am confident they are correct. I have also tried reinstalling TB but the same behaviour occurs.
I have also found I cannot connect with Evolution. I can set up my account details, but when I hit the send/receive button it displays and error saying “Peer failed to perform TLS handshake: A packet with illegal or unsupported version was received”.
So I’m guessing there is a problem not with the email client but with my setup of openSuse.
I installed Tumbleweed from a live USB stick. The only slightly out of the ordinary thing I did was specify my own partitions. openSuse is installed on a partition of a USB drive, as is the swap file it uses. The EFI partition is on my primary hard disk. Other than that it was a bog standard install.
Is there something I’m missing here? What do I need to do to get my email?
I can access my email using my provider’s web interface, so that works.
All advice gratefully received.

Understood that you think it is a problem related to Tumbleweed. At the same time I am sure Thunderbird on Tumbleweed is working for a lot of people including me :wink:

How long ago did you set up your email on another computer/distro where it worked?
To see remote what is wrong, we would need a lot more information.

If you still have another setup that is running Thunderbird, you export the settings and use them again in Tumbleweed, see Moving Thunderbird Data to a New Computer.

Hi Marel, and thanks for the reply.
I originally set up TB on my Mint install a fair while back, like years. Not sure exactly when. But I also have it set it up under Manjaro, Ubuntu, Fedora Silverlue and Kaos at various times in the past, all with no problems. I know openSuse is a bit different (one of the reasons I want to try it!) so not sure if I’ve installed correctly.
I thought it might be to do with the firewall, so I temporarily disabled it, but TB still would not connect.
I also tried transferring the TB files from Mint (installed on another disk) to openSuse as per the link you provided. After a few permissions problems I finally got the files transferred across, but still could not connect.
What information would you need to diagnose the problem? I’m not a guru but I’m okay at following instructions. :slight_smile:

I now have another problem, so I seem to have made things worse… Yesterday I could retrieve my emails from my provider using their web interface. Today I can’t. I get an error message saying the web server user must own /tmp/m or have write access to it, or words to that effect. I checked the permissions on /tmp and the owner was root. I’ve now changed it to my userid, but still I can’t access anything. Not sure what I’ve done… :frowning:

Oops. Now that problem seems to have gone away. All I’ve done is log out and in again. Still can’t connect with TB though.

Please, please do not meddle with the ownership and permissions of /tmp (except may when you know 1000% sure what you are doing). To help you restore, this is what it should be:

boven:~ # ls -ld /tmp
drwxrwxrwt 18 root root 380 Jun 14 14:45 /tmp
boven:~ # 

Specialy check for the t as the last permission!

Well Tumbleweed is not that different, it is all Linux.

What information would you need to diagnose the problem? I’m not a guru but I’m okay at following instructions. :slight_smile:

Well first step is to check your connection. Open up the account settings and go to the server settings:

If it is no problem to you please share the server name, the port, and the connection security and authentication method settings. Keep the User Name private.

Try opening up a console (“Konsole”) and do

ping -c <server name>

Is that working or timing out?

Next you should try something along the lines in this article: How to verify that SSL for IMAP/POP3/SMTP works and a proper SSL certificate is in use.
With the details asked above, I (or somebody else) can help you with the exact command.