cant get my notebook asus tuf gaming FX504 to work with nvidia gtx 1050ti

hello, i am searching these past few days to get nvidia to work, here is how far did i get:

miki@linux-9t2e:~> sudo lspci -nnk | grep -A3 VGA
[sudo] password for root:
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b]
Subsystem: ASUSTeK Computer Inc. Device [1043:18fe]
Kernel driver in use: i915
Kernel modules: i915
miki@linux-9t2e:~> sudo lshw -c video
*-display
description: 3D controller
product: GP107M [GeForce GTX 1050 Ti Mobile]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:443 memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:a4000000-a407ffff
*-display
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:427 memory:a2000000-a2ffffff memory:80000000-8fffffff ioport:5000(size=64) memory:c0000-dffff
miki@linux-9t2e:~>
15.5 GiB
Intel® Core™ i7-8750H CPU @ 2.20GHz × 12
Intel® HD Graphics (Coffeelake 3x8 GT2)
openSUSE Leap 15.0
64-bit

nvidia installed nvidia x server wich i cant get to run from gui, have no idea when i run it manualy in terminal how to use it proprely.
when system starts and i login i get notification “failed parsing nvidia settings”.

hardware information gives me res 1920108060 whle in system inf stands 19201080120.
all those nomodeset, modeprobe, x11, xorg got me so confused that i actually dont understand what suse uses as default before installing graphic driver, what uses after installing g-driver.

i even downloaded file from nvidia cuda_10.1.105_418.39_linux.run and installed it,
nothing really changed.

can someone please help me with noob steps to follow?
should i uninstall all nvidia thats installed and go clean again?

thank you

Have you tried following this guide?
https://en.opensuse.org/SDB:NVIDIA_drivers

yes i have tried that too, i am going to trz to uninstall all of them and go that way again, hope it will work.

Looks like you have an Optimus Laptop with two graphic cards, an Intel and a Nividia.
Therefore you probably need the Bumblebee architecture to get the Nvidia card up and running.
I am not sure about the present situation with Bumblebee, but there is a discussion about the procedure: https://forums.opensuse.org/showthre…ing-in-Leap-15
Standard Nvidia drivers probably won’t do the job, because they cannot handle the Optimus architecture.

Yes, sorry should have spotted you have Optimus as mentioned in previous post.
Hopefully you can get it working for your card following the extra steps for Leap 15 using.
https://en.opensuse.org/SDB:NVIDIA_Bumblebee
If possible I’d suggest rolling your system back with snapper to a snapshot made before your first attempt and start fresh as mentioned in the guide.

It looks like some people have had success.

If the previously provided links fail to produce fruit, OP may wish to consider https://bugzilla.opensuse.org/show_bug.cgi?id=1121246 and therefore using the 15.1 Beta, which is planned to release before the end of May.

Note too that with the NVidia drivers fully uninstalled, there are two ostensibly competent FOSS DDX drivers available, nouveau, the older, and modesetting, the newer technology, most easily utilized very simply by uninstalling xf86-video-nouveau.