Can't get a GUI with 11.4 LiveCD

I seem to have a knack for having systems built that OpenSuse doesn’t like. I remembered this afternoon why I gave up on 11.x - the 11.4 LiveCD doesn’t like my setup, at least in terms of booting into a GUI. I have uploaded two photos I took of the bootup screen, in case the provide information that might be helpful. I am sorry about the shakiness, I have CP and the the 2nd one is harder to read because of that, but it says something about “amd radeon hd 6800 series (chip ID 0x6738) requires KMS” among other things.

Even though I’m really rusty in CLI, I’m happy to give it a go, to get this working, if possible. The two screenshots are and

Any help that can be given will be gratefully accepted.

FWIW, the 11.4 LiveCD also really didn’t like the NVIDIA GeForce 7000M / nForce 610M in my old Acer Aspire 5520 either. :frowning:

Try booting the liveCD with the boot code ‘nomodeset’. One enters this on the options line in the first boot selection menu (grub menu) that appears when booting openSUSE-11.4. Just start typing ‘nomodeset’ and it will appear in the options line.

For Radeon HD hardware, that will try to force a boot to X window using the “radeonhd” open source graphic driver instead of the “radeon” open source graphic driver. If that works, then it may be possible later (after an install) to modify your installation’s config files to use the ‘radeon’ graphic driver.

For nVidia hardware, that boot code will try to boot to X window using the “nv” open source graphic driver instead of the “nouveau” open source graphic driver.

Thanks so much for the prompt reply. I tried that and initally THOUGHT it had worked, as the Suse bootup screen appeared with a graphical progress bar, instead of the verbose listings. But then it shut back down to a CLI screen, as in this shot:

I see 2 possibilities:

  1. There is a known bug in the ‘radeon’ open source video driver for Radeon HD hardware on openSUSE-11.4 liveCD (fixed in later openSUSE-11.4 updates), and that bug possibly coupled with your radeon HD hardware also not being supported by the ‘radeonhd’ opensource video driver could cause what you experienced … Did you try booting and press ‘F3’ and select the ‘safesettings’ boot ? That should boot your PC to the X window with the open source FBDEV graphic video driver. Or use the boot code ‘x11failsafe’.
  2. your downloaded CD is corrupt! Did you compare the md5sum of the downloaded .iso file against the md5sum posted on the download website ? Were they the same ? Did you burn to a high quality CD (+R or -R) media (not an RW) at the SLOWEST speed your burner will allow ? And did you try running the media check on the liveCD to see if that passes ?

I have to confess to have been lazy and not checked the md5 sum before burning, but when I selected “media check” from the boot menu, the end result was “md5 sum OK”. I tried pressing F3 on several reboots, just once the first time, then repeatedly, but never got a ‘safesettings’ mode, so let the normal boot screen come up and typed in ‘x11failsafe’ - it booted in verbose style and listed bootmode as x11failsafe, but the result was the same, no GUI, as in this shot.

Could the message that comes up at the very start of the of the boot process after the kernel’s loaded be relevant? I took screenshots, but in case they were not easy to read, here it is, transcribed as carefully as possible:

address space collision: host bridge window [mem 0x000c8000 0x000dffff] conflicts with Video ROM [mem 0x000c0000 0x000cf9ff]

Possibly important. I read on one site that this error occurs due to the way later 2.6 kernels enumerate adaptor ROMs. Typical symptoms are computers with multiple NICs not starting all adaptors reliably and issues with multi display/adaptor configurations. There is a kernel bug report here:

How many graphic devices in your PC ? Is there both a motherboard graphic device AND a PCI-e graphic device card ?

I read that to fix this issue one can try the boot code pci=nocrs.

So try this boot code:


and if that fails, try:

nomodeset pci=nocrs

I shall check that tomorrow. I am very grateful for all your help. I would LOVE to get this sorted as OpenSuse is my preferred distro, even though I’m typing this in rekonq, using Kubuntu 11.04 LiveCD which didn’t hiccup at all with any of my hardware.

I’m not sure how to check if I have more than one graphics device, but here’s a list of my PCI devices

I’ve found the specs for my mobo - I am not sure, but they don’t appear to include an integrated graphics component:
ASUSTeK Computer Inc. - Motherboards- ASUS P8P67 PRO

An easy way to check is type from a command line:

/sbin/lspci -nnk | grep VGA -A2

and if the upper case ‘VGA’ does not work then try lower case:

/sbin/lspci -nnk | grep vga -A2

Here’s the output:
ubuntu@ubuntu:~$ /sbin/lspci -nnk | grep VGA -A2
bash: /sbin/lspci: No such file or directory
ubuntu@ubuntu:~$ /sbin/lspci -nnk | grep vga -A2
bash: /sbin/lspci: No such file or directory

So I tried again, this time in OpenSuse, and got this (again, transcribed from a photo):
linux:~ # /sbin/lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0988]: ATI Technologies Inc Barts XT [ATI Radeon HD 6800 Series] [1002:6738]
Subsystem: Micro-Star International Co., Ltd. Device [1462:2458]
01:00.1 Audio device [0483]: ATI Technologies Inc Barts HDMI Audio [Radeon HD 6800 Series] [1002:aa88]

Am I correct in thinking this means only one graphics device?

Yes, only one device is detected.

Did you have any success with the boot code:


Since you can boot to a text mode, you could also try the following, … check to see if you can boot to the VESA driver. If you have your PC connected to the Internet, in the text mode type:

su -c 'zypper in mc' 

and press < enter > for the password.

When booting to the liveCD, that will install into RAM the program midnight commander, which is an easy to use text editor (great for use in text mode). You can launch the text editor with the command ‘mc’. You will need to type ‘su’ first before launching midnight commander to get root permissions so as to edit the file /etc/X11/xorg.conf.d/50-device.conf, which you can change to:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "vesa"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


And then if user root, type ‘exit’ to get back to regular user permissions, and try to start X windows with


Hopefully the vesa driver will work.

Note in the liveCD, the username for the regular user is ‘linux’ and the password for both the regular user ‘linux’ and for ‘root’ is < enter > .

The Radeon HD6800 series of hardware is very new and its support under openSUSE-11.4 is a bit problematic. Your only option for this test may be to install the proprietary driver off of the Internet, which is only possible with the liveCD if your PC has lots of RAM (~4GB or more).

Thank you so much for all your patient assistance. I tried “pci=nocrs” then I tried booting into VESA mode from the video options on the bootsplash, then I tried both, “pci=nocrs” and VESA. None of them worked, although “pci=nocrs” does kill the warning that normally starts the boot process. I do have 4GB of RAM, but I think I might have to leave it for now, and maybe just keep an eye out for improved support for the Radeon 6800 in openSUSE-11.4 VESA looks huge on my screen and there doesn’t seem much point having a 1920*1080 native resolution screen if I have to use VESA. I feel a little guilty about giving up for now after all your efforts to help, but I’m finding the lure of “just works” (as Windows 7 & Kubuntu 11.04) too tempting, especially in terms of productive use of my time.

The point of using VESA is to get to the point where you can install the proprietary driver on a real install. Running a CD boot for production does not make a lot of sense since any changes will be lost. It is mostly meant to be used to test things,

Yes, I understand that. It’s just that for now, even in those terms, Kubuntu is an easier option, since it appears to have flawless support for my card. I was looking for something I could install to a 16GB stick (or an external USB HDD) for a portable OS, and one that “just works” will do, even if it’s not my preferred distro.

@ maxqnz

Indeed gogalthorp’s point is what I was getting at. Once you can confirm VESA works, one can then test more easily the functionality with the proprietary fglrx driver which should work with openSUSE-11.4 and the HD 6800.

I know this is slow and time consuming for you, but that IMHO is due to a lack of familiarity with openSUSE. The sort of tests I have had you run, are something I can do at work in my 30 minute lunch break. But thats easy for me because I know exactly what to try, and do not need to correspond with someone over a slow forum thread, trying to make sense out of their less than perfect typing style.

For example, see post#27 here where I tested the proprietary driver from a liveCD on radeon hardware: OpenSuse 11.4 startup problems

Thanks again. I’m not actually that unfamiliar with openSuse, having used several 10.x releases and 11.0, after having previously used several other distros starting with Mandrake 6.2 several years ago. I AM very rusty though, that’s become very obvious to me. As for my less than perfect typing style, that may be at least in part due to something that I’ve discovered over the last day through implementing your suggestions.

When I was regularly running dualboot systems, and actually spending most of my time in Linux, I had two more or less fully functioning hands. The experience of having to spend a lot more time back in CLI over the last day has been educational, since it’s highlighted how much more time-consuming that is with only one functioning hand, and poor hand-eye co-ordination that makes typing a slow, error-ridden exercise. Even just getting that simple “/sbin/lspci” line typed in accurately took me more than 5 minutes. It reminded me of why I abandoned dualboot systems, because I use Dragon Naturally Speaking a lot, and decent speech recognition software for Linux wasn’t available when I left Linux, at around the time 11.1 came out. That’s why I’m leaning toward using a distro that already works with my hardware, to reduce the amount of typing I need to do.

< gulp > … actually, it was MY less than perfect typing style I was referring to. Your posts have been very clear.

This is IMHO a very graphic specific area of openSUSE, and one that I have spent a bit of time over the past year looking at, as I have found my help is needed less and less on audio issues, and I tried to find an area where I could provide a better contribution to openSUSE.

So I think my comment about ‘experience’ was very poorly worded as we are likely into more advanced areas here.

Sorry to read about this.

I hope you eventually succeed, and if you do succeed, stick around and help us.

This is an area where we could really use knowledgeable users contributing to our forum, as the sort of tools needed to help those with less than fully functional capabilities is something most of us have no idea about.