Can't format

I’m new to linux and this is my first post…

I have two SATA hard disks of 160 GB each. I have windows 7 on one of the disks and the other one is left empty (Unused).

When I tried to install open SUSE 11.2, I select the expert partioner. I could see the disks as,


and not as /dev/sda or /dev/sdb.
Under the disks section, i could see sda and sdb. But when i tried to select sdb and try to add a new partition, I get a message,

"Disk in use, cannot add partition"

Can anyone help me please…I want to install SUSE on the unused disk.

motherboard: asus p5n e sli
grapics: nvidia quadro 540
cpu: intel core 2 duo
hard disks: Seagate 160GB x 2

Do you have your drive configured in raid?

Or has it been part of a raid config before?

Are you using a CD or DVD to install with. If using the CD and running the Live Desktop, make sure you have not tried accessing any of your HD’s.
Or run the installer from the boot menu, rather than going to the live desktop.

Sounds like it is RAIDed.

If so that second drive is being used.

Yes I’ve configure the hard disks in raid before when i was using windows xp. Now im using windows 7 without the raid configs.

I was trying to install Suse through a DVD.

What should I do???

Have you got a working backup of anything you may want to keep?
(and checked that backup)?

Did you setup the RAID in the BIOS? Sure the disk is not used?

@dvhenry, yes I have created the back up of everything I want to keep.

@Knurpht, I have deleted the disk using Gparted using a live ubuntu cd.

I think I have turned off the raid option in the bios. I’ll have to check it again though… :)(One of my friends did the Raid setup when I was using xp)

It must be some remains of the raid setup, otherwise the problem would not exist. If not in the BIOS, then on the disk.

What you can do:

  • disconnect the 2nd drive, see if Win7 boots normally. If so
  • disconnect 1st drive, reconnect 2nd drive, see if you manage to install now. If so
  • reconnect the 1st drive, boot from the DVD, choose the repair option. It will check the bootloader and repair it, this should make the system bootable for at least openSUSE, we’ll help you from there to get you windu system accessible.

O, and a very warm welcome to the forums

Thank you :smiley:

I’ll try that and keep you guys update… on my endeavor.

Hi folks,
I’ve removed the drive containing the windows 7. Having only the unused disk, I put in the open Suse 11.2 dvd and booted up from it. During installation, I left every option as default.

On reaching the formatting stage, it showed me that its gonna create *raid extended partitions for all the mount points.

From my bios, the nvraid option is disabled.

Other than that, everything went smoothly and I could see the beautiful kde.
I shut it down and restart it again; everything worked normally.

So I turned it off again, plugged in the windows hard disk . Pushed the power button. I was greeted by booting screen and then suddenly it shows me the following screen

What do you think is the Problem?:’(

The problem is OpenSUSE thinks the drive is part of a raid array.

When you create an nvidia raid it writes a bit of information to the raid disks. You need to erase this info.

Download this KillDisk Free
Active@ Kill Disk. Hard Drives Eraser. Free Download.

It is a windows program.

First make sure the nvraid is disable in the bios.

Use your Windows 7 OS and use KillDisk to erase your second disk drive. Perform a write 0, it shouldnt take long on a 160GB drive.

When it is complete, turn off the pc. Disconnect your windows 7 hard disk.

Now install opensuse on your second disk, the installer should not report /dev/mapper/

In which case proceed with the install, we will have to sort the grub loader to include win7 later on.

Thanks a lot… I did that and now im the proud owner of an open suse 11.2 system.You were right all along… I used killdisk and suse now recognized the unused disk as unraided.

It even recognized the windows partitions in the other disk(which is still raided) and it created mount points for them during installation.

Still have a small glitch though, my system would always boot up from the windows boot manager and not from grub. So every time that I wanna use suse, I have to manually select the disk to boot from.

I would like to fix that problem on my own.So thank you all for your help…


Cool :wink:

I am so tempted to post the solution to your small glitch problem :stuck_out_tongue:

As a hint. You want the Suse disk to be the first boot so the boot lodes grub. You will need to add the option to boot Windows in the /boot/grub/menu.lst file

You may or may not (probably not) need to edit /etc/fstab file to set your mount options to point to the correct drives. Changing boot order also changes sda to sdb etc.

Keep your temptations at bay dude :stuck_out_tongue:

ive got hold of this one :smiley: