Can't find windows boot option anymore


I have installed OpenSuse 11.1 on my windows machine on a USB drive. The partitions:

Internal hard drive: Contains two NTFS partitions - first is the primary Vista boot and data partition and the second partition is the recovery partition.

USB external hard drive: Contains two partitions: - one is an NTFS partition, and the other is a Linux partition which has OpenSuse 11.1 installed.

Until yesterday, during reboot, I used to get OpenSuse and Windows as options to boot in the green OpenSuse boot screen. The machine has been booted and working on OpenSuse for the past several weeks. This morning, the OS couldn’t find any files on the Linux drive - so I rebooted to see if will fix the issue. During reboot, it gave a GRUB 18 error. I tried the “repair installation” option during OpenSuse reboot. I chose the automatic repair option. It seemed to work fine - and it boots OpenSuse fine now, but I do not see the windows boot option any more.

Under OpenSuse, I see /Windows/C mounted and with all the files intact as far as I can tell. Problem seems to be in the boot record.

Please advice me on how I can recover the Windows boot option.

Thanks in advance.


can you check the menu.lst file in /boot/grub??
if you dont see the windows option just add the same.
like in my case with two hard drives,1st one having xp and linux in the last partition of second hdd:

title windows
rootnoverify (hd1,5)
chainloader (hd0,0)+1

hd0 being the 1st drive and 0 the first partition.

Perfect… That fixed it. Thanks a lot.