Cant find hard drive :(


[openSUSE 11.0, Gnome]

I am fairly new to linux and such, trying differnt distros and so on. I started with ubuntu, which was good, then decided to try another one ( aimed more for finding a good one of my ps3 ), and opneSUSE was the one i decided I’d try. So far i love it, a lot, far more then ubuntu.

The current problem Im having is with my other hard drive :stuck_out_tongue:

I have 2 HD, one sata, the other IDE. In ubuntu the other hard drive would show up as a removable storage device, this came in handy seeing as all my stuff is on my xp OS ( i game so i cant make a full transition to linux ). I dont want to have all my videos and pix and stuff coppied on both HD’s.

In the disk usage manager it sees the other hard drive ( along with the partion manager ), but i cant access it.

any idea how to get on to my other hard drive so i can get to my pix, vidoes, ISO’s and such?

If the disk manager (YaST > Partitioner I presume?) sees the disk, select it and click EDIT. On the left bottom you can set a mount point for it (like /disk2 or other) - make sure not to touch other options like format (not selected by default).

When you have applied that the disk should be accessible through the set mount point.

Hope that helps,

thanks :smiley: I’ll give this a try

Hi. It’s not clear to me: you can’t access the drive because it is not properly mounted or the problem is related to permissions issues, so the system doesn’t allow the user to access the drive? Does it happen even when logged as root?

I can now access the drive, but I can not edit save or delete any thing on it? I assume this is a security from windows… idk… how do i over ride this?

The windows security should not come through to Linux. Like bcrisciotti mentions, it’s probably how your mount parameter is set for the partition.

Could you post /etc/fstab?

When mounting NTFS what I do is replace the [users,gid=,… ect] bit (in fstab) to defaults ]. That sets it so all users have full access. You will have to re-mount the NTFS mount or reboot to make the change effective.

Hope that helps,

ps. There is also a little utility ‘ntfs-config’ that you can install using YaST > Software Management.
After installing run it from your menu to set default rights to NTFS formated media.

So now we know it is a permissions issue. First figure out the mount point of this file system. If you don’t know then open a console, log in as root and perform the command ’ mount '. It lists your mount points. Figure out the drive and write the associated mount point. It will be something like ’ /windows/something '. Now give it the permissions, always as root: chmod 777 /windows/something. Now should be ok for every user and can log out root