Can't edit grub via yast Boot Loader

The settings shown in Yast’s Boot Loader are not the same as those in the /boot/* files. I cannot seem to change the “device/by-id” settings.

Inside the Boot Loader gui program, the /boot/grub/ says:

“(hd0) /dev/disk/by-id/ata-ST525…”
“(hd1) /dev/sdb”

but the actual file in /boot/grub/ shows:

“(hdo) /dev/sda”
“(hd1) /dev/sdb”

No matter what I do I cannot seem to change the file or any other grub configuration file from YAST.

First: what is the problem? System not booting?

If realy needed you can edit the file by executing an editor with root privileges:

The command will ask you for the root password.

BUT: you have to have good reasons to make manual changes. If everything works, do yourself a favor and leave it like that.
IF NOT, let Yast’s Bootloader Configuration suggest a new config for your system.

First I support Knurpht, do not change when it works or if you hve another very good reason (and the knowledge).

Have you looked what /dev/disk/by-id/ata-ST525… realy is? It is a symbolic link to /dev/sda? and thus the circle is closed.

Thanks guys for your comments.

The Grub issue has come up because I am trying to build a new base image for deployment at my work.(I use Clonezilla for imaging.) Right now I have about 15 computers running SLED9 and another 30 or so runing OpenSUSE 10.1. In both of those distributions, GRUB is configured to use the “dev/sda” format which allows for imaging. The “/device/by-id” gives problems when imaging so that is the reason for trying to change the Grub configuration. Both Sled9 and 10.1 can easily be adjusted using the Boot Loader tool so I’m stumped here. I have tried changing the Grub config and fstab setting during installation but no luck. Clearly OpenSUSE 11.1 and SLED11 have a different default configuration. The Boot Loader is getting is information and writing that to the grub config files.

I’m open to any suggestions.

Just to clarify - you’ve tried editing them directly as text files after installation? Presumably the GUI can say what it wants, if the actual config file has the right thing in.

During installation, you can specify how you want Suse to mount the different partitions. I thought this would also control the Grub configuration since Grub mounts the boot partition first. I didn’t seem to work for me. Still, I can’t figure out where the Boot Loader tool is getting its information.

I’ve buggered up the Grub configuration so that it won’t boot directly so I’m using the Grub Rescue disk to boot. I’m not concerned about that since I can rebuild if necessary or manually edit Grub (when I learn how to do that) if I have to.

I think I found it. In the Sysconfig Editor, there is a section under Yast2 called “DEVICE_NAMES” that was set to “id”. When I changed it to “device”, the Boot Loader tool displayed the proper settings.

Grub is still not working properly but at least I can take a crack at fixing it now.

Use a live cd or the dvd:
Details here
HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

Thanks, that page was very useful.

I haven’t read much of it yet (and it does seem to have some inaccuracies in), but I’ve found this one useful too.