Can't configure slick greeter

Creating /etc/lightdm/slick-greeter.conf and making changes doesn’t yield any results, is there a different path in opensuse?

It maybe don’t need a new one.
You just have to edit the /etc/lightdm/lightdm-gtk-greeter.conf
See this link on how to set the default theme.
https://wiki.archlinux.org/title/LightDM

Just save the file of the old .conf file in case
it will not work.

In xfce the background and icon themes etc. of lightdm can be edited
in the Settings Manager-lightdm gui with root permission.
I don’t know what DE you are using.

There are old threads like this in this forum, do a search.

Hi,
I tried using the update alternatives in yast2 to change the SDDM to lightdm with slick greeter in tumbleweed.
The slick greeter was installed using the yast2 software management.
On a tumbleweed with the latest snapshot with SDDM, it won’t allow changing from SDDM to lightdm, maybe a problem on my install.
On a tumbleweed with the snapshot from two weeks ago, I can change SDDM to lightdm and I can change from the default lightdm greeter to slick greeter.
Note: the slick greeter is in the option in the yast2-alternatives

If this will work for you this will be the easiest way. You only need a point and click by the mouse.

lightdm-gtk-greeter.conf is not there for me because I only have slick installed, think I already tried making it. I’m using Cinnamon and slick comes with it.

Hi, I think you misunderstood me, I don’t want to change the greater, I want to configure the slick one, namely change the background image.

If you have

LightDM GTK+ Greeter settings

It’s a gui tool. When you open it it will ask the root password.
Then you can edit the background image etc.

You can run the command

lightdm-gtk-greeter-settings-pkexec

in the terminal also.

tried that already. Slick greeter works separately than lightdm, it’s a fork and not a theme for lightdm as I understand. thanks for the help anyway.

I had the same question running leap 15.3 :).

The configuration lives in “/etc/lightdm/slick-greeter.conf”. If I remember correctly, I had to create the file.


[Seat:*]
#greeter-hide-users=true
greeter-show-manual-login=true

[Greeter]
# background = Background file to use, either an image path or a color (e.g. #772953)
background=/usr/local/share/wallpapers/Dark_Gecko.png
theme-name=Adwaita-dark

Have a lot of fun!

Hi,
Apologies for barking up the wrong tree.:slight_smile:
so I dug a little bit more and the one that works with the background is

Creating the file like so:

/etc/lightdm/slick-greeter.conf

Inside the slick-greeter.conf I have this:

[Greeter]
#change the path to your background. 
background=/home/container/wallpaper/Fractal.png
draw-user-backgrounds = false

Please take note regarding the “draw-user-backgrounds = false”
There is a white space between background and equal(=) and equal(=) and false.
I search around and I read it might be a bug.

You can edit some of the config using

dconf-editor 

under x - dm - slick-greeter.

Any config you do in /etc/lightdm/slick-greeter.conf will override the setting in dconf-editor.

Addtional info at

/usr/share/doc/packages/lightdm-slick-greeter/README.md

Hope this time I will be correct.:wink:

Too late to edit my post above.
If just disabling the

draw-user-backgrounds

In dconf-editor, the slick-greeter background shows and fade to the user desktop background which is kinda nice too.
Could be just happening to my desktop it might be different on yours.:\

Thank you, it finally worked, although it didn’t seem to recognize the path being inside user home folder, so had to put outside of it. dconf didn’t work for me for some reason, I guess there is some other file that is taking a priority.

I do not know that login greeter or any of the things you try to configure in it, but as a login greeter it is of course not configurable from within a user’s home directory, and thus to be done by the user. How would you think it should work when different users each a made a different configuration within their home directory?

This is typically a system function and thus only configurable by the root user in a file somewhere in the system area (like /etc or so).

I meant I had the wallpaper picture in home directory, not the configuration file. it’s not obvious at all that it would not work.

That was

/home/container/wallpaper/Fractal.png

?
Maybe some ownership/permission? You did not show anything about it.
In any case, it looks strange to me to have something that belongs to the system inside /home.

Lightdm runs greeters under non-privileged user by default, so normal access restrictions apply. Check permissions of your file and all directories in its path.

Probably. It is a separate rotating disk mounted to be accessible to two operating system by the users.