Can't boot xen kernel

Hi, I did a fresh install of 13.1 with the Xen software (kernel, etc.) at the time of install. It added a grub menu entry for booting opensuse with the xen kernel, but when I try and select it, it hangs on “loading initial ramdisk”. Pressing ‘e’ to view the source for the command, everything looks to be correct… Here’s from grub.cfg:

### BEGIN /etc/grub.d/20_linux_xen ###
menuentry 'openSUSE 13.1 GNU/Linux, with Xen hypervisor' --class 'opensuse-13-1' --class gnu-linux --class gnu --class os --class xen $menuentry_id_option 'xen-gnulinux-simple-cbaf6cfb-eefe-4dd8-9b28-0f51ad105c59' {
        insmod part_gpt
        insmod ext2
        set root='hd1,gpt2'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt2 --hint-efi=hd1,gpt2 --hint-baremetal=ahci1,gpt2  cbaf6cfb-eefe-4dd8-9b28-0f51ad105c59
          search --no-floppy --fs-uuid --set=root cbaf6cfb-eefe-4dd8-9b28-0f51ad105c59
        echo    'Loading Xen 4.3.0_14-1.3 ...'
        if  "$grub_platform" = "pc" -o "$grub_platform" = "" ]; then
            xen_rm_opts="no-real-mode edd=off"
        multiboot       /boot/xen-4.3.0_14-1.3.gz placeholder   ${xen_rm_opts}
        echo    'Loading Linux 3.11.6-4-xen ...'
        module  /boot/vmlinuz-3.11.6-4-xen placeholder root=UUID=cbaf6cfb-eefe-4dd8-9b28-0f51ad105c59 ro   resume=/dev/disk/by-id/ata-Samsung_SSD_840_PRO_Series_S1ATNSBF113184Y-part3 splash=silent quiet showopts
        echo    'Loading initial ramdisk ...'
        module  /boot/initrd-3.11.6-4-xen

The xen files are all present in /boot, what could be going wrong? the regular kernel boots fine. Thanks for any help.

Bit of an update, I tried installing Factory and have similar things happening, except it gets to the ‘loading initial ramdisk’ stage and the entire computer reboots itself! now I’m really confused :’(

secureboot is disabled, btw. system is not overclocked. it’s a 4790K on an asrock Z97M-ITX/AC motherboard, vtx and vtd enabled. tried ‘nomodeset’ kernel option and that didn’t have any effect.

I would do a normal install and just add Yast2-vm during install.

After install do the update stuff en go to yast2 and run the " Install Hypervisor and tools".

This would install and configure a correct xen-kernel also in Grub2.

I had initially done it that way before doing the clean install. It appeared to configure everything correctly but had the same result. For the heck of it I threw Fedora on there and installed Xen, and it also exhibited the rebooting problem at ‘loading initial ramdisk’, so maybe there’s some hardware incompatibility?