Can't boot with ACPI on

My openSuse install can’t boot/login with ACPI enabled. I disabled ACPI and have been using it for a while, but would like to get ACPI working.

When I did the install from the livecd it would hang when loading the kernel. I would see the progress indicator get to 99% and then my computer froze. I disabled ACPI from the options and was able to install.

But I never got any error messages or any other output so I don’t know what module was causing the problem when being loaded.

Help is appreciated, thanks!

If you have taken acpi=off out of the boot menu
When grub boots press Esc.
Watch the text as it scrolls for any errors

You can also try using each of these options (separately) from the boot menu screen (typing in the dialog box below):


You forgot “acpi=ht” which worked for me

This seems to be a known problem, please look at
Bugs:Most Annoying Bugs 11.2 - openSUSE

For my MB GA-MA770-DS3 the BIOS upgrade to F7 worked