Can't boot to openSUSE after selecting Windows in KDE restart menu

Hello everyone,
I’m using openSUSE Tumbleweed x64 with latest packages dual boot with Windows 7 x64. My laptop is using MBR.
As described in title, once I restart my laptop via restart options in kickoff menu, I see an dropdown menu that lists all boot entry in my Grub2 menu look like this:
I try to choose Windows 7 x64 in that list. Next boots, after the “Grub loading” screen (and some few lines but they are too fast to read), it boot directly to Windows 7 without waiting for me to choose the entry.
I try some key but it still happen (Esc, Del, Space, Enter, Alt…)
Anyone help me.

Are you using btrfs as root?
Then grub2 cannot set back the entry you chose, and because it is set grub2 doesn’t show a boot menu either.

You’ll have to boot to a livecd (as Windows cannot access a btrfs partition either), mount the partition and remove the file /boot/grub2/grubenv.

And then do not use KDE’s option to select a boot entry again. Or setup a separate /boot partition with some other file system, ext2 preferably.

That’s btw.

Thanks! It works!