Can't boot to KDE after resolution change

Hi all!

I’ve just installed OpenSUSE 11.0 in VirtualBox on my old XP laptop so that I can try to learn Linux. I installed successfully, and immediately decided I needed to work on the resolution (it was at stock 800x600). I opened up Sax2, and changed my monitor type to LCD 1680x1050 - which is the maximum resolution of my laptop. This did not affect the options I had for resolutions, which were all 4:3 ratio. I figured maybe that needed to take affect first, so I hit ok and restarted.

It came right back, still in 800x600, so I opened up Sax2 again to see if I had more options for resolutions. I didn’t. I set it to 1600x1200 and restarted hoping that VirtualBox would stretch the display to fit. It booted back up and the resolution had been successfully changed to 1600x1200, with the bottom of the screen being cutoff (I could use the scroll button on my mouse to scroll the entire screen).

I then went back to Sax2 to look for other options. I then noticed that there is a setting to change the physical dimensions and ratio of the monitor, so I selected 17" and 16x10. I hit ok, restarted, and it came back still in 1600x1200 and cutoff as before. No new resolutions in Sax2.

I decided I’d just figure it out later, and switched to a resolution that would fit entirely within my actual resolution (1280x1024). I restarted, and now KDE won’t boot.

The desktop starts to load, but it looks like it’s in 16 color mode, there are vertical stripes on the desktop, and after about 2 seconds it restarts to login where I can choose another desktop manager. I’ve been using IceWM to get back to Sax2 and attempt to change settings, but nothing I do is working, and for some reason when I switch back to 1600x1200 it just doesn’t take. It remains in 1280x1024 seemingly whatever I do.

This could be something incredibly simple for all I know, but I wasn’t able to find any similar problems searching google. Any ideas?


Go to the boot splash screen and on the line type init 3 and hit enter.
type Root and then pass.
Then type "sax2…enter
Go in sax2 and configure your monitor.
Be sure!! To test to make sure it works and then save…exit and reboot.

I’m a little new to this… I’m not sure exactly what the configuration should be. As I said, the monitor is set to “LCD 1680x1050 @60h”, which seems to be what I want to be using. Is there some other generic laptop monitor type that is more appropriate? After changing the monitor settings, the available resolutions didn’t change.

On another note… for whatever reason, I restarted several times while in IceWM, and eventually that one changed to 1600x1200, and now I’m back in KDE. However, I’m assuming when I switch back to some other resolution my problem will be back.

Keep in mind you have installed a machine (albeit virtual) inside a machine. The virtual machine has its own virtual hardware. The size of the monitor in the virtual machine cannot be the size of the real machine’s display; it won’t fit. It will be the size of the window you want on you real machine’s desktop. When you install Linux inside the virtual machine, the resolution will initially be set to whatever you select at installation. Since you will not have yet installed the VBox Additions (you have installed the Additions, right?), the resolution will be limited to what the vesa driver supports, as your real graphics card and its driver is not being used. With the Additions, the VBox video driver is installed. It supports a wide range of resolutions, which the manual explains needs to be set up by hand in the xorg.conf file. The Additions also support dynamic resizing of the virtual machine window, i.e., changing the size of the window on your desktop that the virtual machine is running within and on-the-fly changing the resolution configured inside the virtual machine. That’s the summary. Please consult the VirtualBox manual; it details all of this.

I’m not running VM.
But in sax2 can you configure your monitor?
If so what displays does your monitor offer?
Also what display driver do you have loaded?

Thank you mingus725’s!
I learned something there. I wasn’t aware how VM display worked.

Thanks Mingus725! I actually worked on trying to get that installed, but I’m running into some issues. I got all the required packages installed, but it’s giving me an error about the header files not exactly matching the version of the kernel that I have installed. From what I read, that shouldn’t matter as long as the header version is older than the kernel version, but it still won’t let me install them. The standard repos only give me a single option for the version of the headers, so I’ll have to do some research to figure out how to fix it. I’ll check the virtual box documentation to see if this issue is mentioned.

Now I know what I need to do to get my resolution issue fixed! Thanks for pointing me in the right direction!