Can't boot into GUI after installing Awesome Window Manager

Shortly after installing Awesome Window Manager in openSUSE 12.3 I logged out of the session and looked at the choices to boot into desktop environments. There where tons of extra ones I’ve never directly installed on my system. The only one’s name I can recall is Sawfish. I booted into a very strange one. I can’t recall the name. After so I booted into a black screen with a white cursor and purple framing around the screen. I had to manually shut off my computer to get out of it. While in it it is impossible to do anything other than move your cursor around the screen. Now whenever I try to log into openSUSE it defaults to that DE and makes it impossible to do anything else. Is there a way to get to the log in menu to go into a usable DE?
EDIT - I’m almost positive these DEs come from the Awesome repos.

Have you tried CTRL-ALT-BACKSPACE (do it twice) to kill the desktop session. That would normally get you a desktop login prompt.

Do you use “auto login”? I used to, and this happened to me when I tried an alternate desktop that didn’t work (I forget what it was). I went into yast via the terminal (after ctrl-alt-F1) and set it to not auto login, then I could choose KDE, or some other DE.

Well that worked.
Exactly how do i do this? And what are these other DEs anyways?

I’m not sure what you are asking - are you asking how I set up auto login? If so, I always selected it when installing openSUSE (I don’t do that anymore, though). Or are you asking how to disable it? That’s in Yast, in “User And Group Management”, on the “Users” tab. Click the “Expert Options” combo box, select “Login Settings” and you will see the check box for auto login.

As for the other DEs, I was referring to IceWM, and a few others that were installed by default, I forget what they were, though. I guess they were window managers, probably not desktop environments like KDE and Gnome, I may have used the wrong terminology.