Can't boot from USB drive on Dell laptop (but Leap works)


I am trying to install openSUSE Tumbleweed on USB (SSD) disk and after successful installation it won’t boot on Dell Latitude 5300 laptop (8th gen. Intel CPU). The USB drive is detected and I can select it as boot drive, but it just drops me to a (BIOS) menu with 3 options:

  • Press F1 for boot menu
  • Press F2 to enter BIOS
  • Press F5 to run onboard diagnostics

However, it works without issues on (8th gen.) Intel NUC and another (non-Dell, 11th gen.) Intel CPU laptop. I tried using different USB ports, and even a different USB hard drive but with the same result. Unfortunately, I need this to run on this Dell laptop.

It is using UEFI, Secure Boot is disabled, default GNOME desktop installation that is installed from USB flash drive. Nothing fancy, just a regular install with default settings:

  • Boot Loader Type: GRUB2 EFI
  • Secure Boot: Disabled
  • Trusted Boot: disabled
  • Update NVRAM: enabled

I tried installing Leap 15.4, with the same settings and it works, even on this problematic Dell laptop, but just until I plug a different USB drive and boot off of it. Also, it changes boot entry from opensuse to UEFI: Realtek RTL9210B... (or similar, depending on USB HDD case model). Tumbleweed does not work at all. Other distros (Fedora, Pop_OS) work without issues on this Dell laptop. I am not sure what is the source of the issue but seems like it’s related to something with boot entries. If you have any ideas or pointers, I’d be happy to hear them.


It is far from clear what you are doing.

If I do a normal install, but to a USB drive, I think it just treats that USB as if it were an internal hard drive. But maybe your BIOS does not like that.

My preferred way to install to a USB drive is to install for booting that way. You might need to mount that drive, and chroot into it. And you need to be sure that the EFI partition on the USB drive is also mounted. Then try:

shim-install --removable --no-nvram

Thanks for your reply.

Indeed, I am trying to do a normal installation, just as I would do it on a computer without any OS installed. But instead of installing OS on internal hard drive, I would like to install it on a USB hard drive. The interesting part with BIOS is that it does boot from that same USB hard drive, on the affected Dell laptop, if Fedora or Pop_OS (based on the Ubuntu) is installed. openSUSE will boot on different computers, and I tried using different USB drive but the end result is the same.

It seems that only combination of openSUSE on this specific laptop is not working, changing OS or the laptop results in a success.

I would like to try your recommendation but I am not sure how to do it. Is there any documentation you could point me to?

(1) Boot the install media to the rescue system.

(2) Mount the root partition on your USB drive at “/mnt”


mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys

(4) No go into chroot mode:

chroot /mnt
mount -a  ### mount any other needed file syste
shim-install --removable --no-nvram

(5) reboot and see if it works.

Thank you nrickert! The way you recommended worked great. That was the missing part. I’ll have to do some reading on shim-install :slight_smile:

Many thanks for your help!

I’m glad things are working again.