Can't boot after installation - black screen with blinking cursor

I’m trying to install opensuse 12.3 on a computer with 2 harddrives but I can’t boot into it after installation.

sda has windows and a bunch of unused space which I’ll partition later
sdb should have:
/boot ext4 160 mb
ext4 of 100 gb which is an lvm split into /, /home and swap.

If I put boot on sda, install appears to work, but if it’s on sdb, I get a black screen with a blinking cursor (BIOS boots sdb first).

fdisk output:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x26f73017

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   211720634   105756893+   7  HPFS/NTFS/exFAT

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00018eef

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048      321535      159744   83  Linux
/dev/sdb2          321536   234440703   117059584   8e  Linux LVM

Any ideas? This is very frustrating.
I’d like the boot to be on sdb since that’s an ssd drive. Sda is only going to be for windows and extra storage.

Starting the boot loader setup on the live cd, I get a message saying “Because of the partitioning, the boot loader cannot be installed properly”


UPDATE: Selecting sda as first device to boot works. Grub loads and all is fine.

So I guess the boot loader is loaded onto the master boot record on sda and the gets redirected to /boot on sdb?

Bit impossible to answer when one reads:

ext4 of 100 gb which is an lvm split into /, /home and swap.

One can use LVM (for a reason of course), but you do not create Logical Volumes on a ext4 (or any other type) file system. This is realy ???

Is this a UEFI machine or the old BIOS. This is important to know. If a new machine it is probably UEFI but if it is a couple of years old most likely BIOS

So do you see anything during the boot like the grub menu? ie at waht point do you get the blank screen. This could be a video problem but we would need more info to figure that out. All our crystal balls are broken and only you can tell use what you see and what you have.

It’s a BIOS. I see no grub menu at all. Just the regular motherboard bootup screen and then black screen with the blinking cursor. (sorry, I thought that was clear)

Using the sda hdd as first boot, I boot into opensuse no problem (see second post), so it’s not a video problem.
I ran the boot loader setup once in there and tried installing it onto /dev/sdb. Got no errors but still unable to boot from second hdd.

What is your question?
I gave a rough outline of the logical volumes within the group. Since I can boot fine into the system using the other harddrive (see post #2), the issue is not with the lvm.

If the LVM is encrypted you need to have a separate unencrypted boot partition out side of the LVM

Do you select sda or sdb during installation or try to change boot drive on installed system using yast?

Yeah, that’s what I ended up doing but no luck (one of the lvm volumes is encrypted):

Yup, specifically selected sdb so it doesn’t bother with sda.

Thanks for the suggestions!

You did not answer my question. You selected sdb during installation or you tried to change bootloader location after installation?

Sorry, but I can not understand the sentence I quoted (and I hate rough ooutlines, they allways lead to misunderstandings)). And thus stopped reading there and tried to get more clarification. When you think it is of no importance, then we leave it at that.

Ah, sorry.
I selected sdb during installation and when that didn’t work I also tried resetting up the bootloader after the install. Here’s what boot loader says:

At this point I’m willing to give up on this. /boot is on the SSD drive (sdb) so it still be technically taking advantage of the improved speed.
Yes, the initial boot happens from the other harddrive but whatever.

It’s more of a curiosity/principle thing. I just don’t see why it wouldn’t boot off of sdb.

Changing bootloader location after installation does not work, I just tested it again on 13.1 M3. See

As for installation - if you used the same selection (i.e. MBR), you let yast select actual disk. And it is most probably will be sda indeed. To be sure bootloader is installed on /dev/sdb you need to uncheck everything except custom and select custom location /dev/sdb.

That worked!
I set it to custom and sdb but I thought it’s not working cause when I restart the boot loader setup, the only option selected is still MBR.

That said, rebooting and setting sdb first in the boot sequence now works fine.

Thanks for that! :slight_smile: