Can't boot 5.8.2-1

Just updated to 5.8.2-1.

Grub menu as expected.

Grub console wibbles about diskfilter writes not allowed (or something similar).

I then get a screen where something wibbles about failing to create a virtual terminal (it think it always says that but gets blanked by plymouth before I can read it), says something about dracut requiring parameters, and offers me a login prompt, which doesn’t allow me to log in.

I don’t know where to start with this one. Is it something I’m going to be able to fix locally, or should I just keep running the old kernel until help arrives in the form of an update?

Any advice on how to proceed would be very welcome.


You should be able to boot the previous kernel (the “advanced options” menu line).

Yep, am doing that, the question is: is this a problem that I can fix, or should I wait for an update?

At Grub, select your 5.8.2 kernel and press the e key to edit, use the arrow keys to get to the end of the linx or linuxefi line and add the following to disable plymouth temporarily;


Then press F10 to boot, press the esc key to see more messages. Are you using the nvidia driver?

not nvidia.
Did that. No Joy.
Not much more in the way of messages when pressing esc:
the exact messages I see after the boot screen are:

2.5144463] systemd[1]: Failed to start Setup Virtual Console
[FAILED] Failed to start Setup Virtual Console
[DEPEND] Dependency failed for dracut ask for additional cmdline parameters.
*[FAILED] Failed to start Setup Virtual Console
**[FAILED] Failed to stare Machine Check Exception Logging Daemon.

Welcome to openSUSE Tumbleweed 28(numbers illegible in my notes) - Kernel 5.8.2-1-default (tty1).

laptop4k login:

Not of which leaves me any the wiser :frowning:

Need to go to bed now: it’s 4a.m. here. Will try again tmrw.

This thread subject says “can’t boot” but you are booted up to login prompt, just not in graphical mode. Can you login now?

No… Perhaps I should have restated what I said in my initial post: that login prompt doesn’t work.

Or your keyboard isn’t working to type in? You need to be a bit more verbose sometimes :wink: If the keyboard is not working, can you connect another one to test? If it’s not accepting your username/password, is it possible to see if you can ssh to it from another computer?

From memory, the virtual console error was related to a font issue, maybe that’s why you see funky characters?

cat /etc/vconsole.conf

The keyboard worked fine: when I typed in ‘root’ and pressed return, instead of a passwd prompt, I got ‘Invalid Login’ (or similar).

HOWEVER, I now have this FIXED!.
I basically hit it with a bigger hammer. Running the old kernel, I replaced my custom Plymouth theme (just in case, though I don’t expect that was the issue: it was just edited artwork from an old Tumbleweed theme), and performed a forced update. Rebooted successfully and reinstated my Plymouth theme.

So basically just a borked update.

Sounds like initrd didn’t rebuild with your plymouth theme… Do you have a dracut file for this? I don’t run plymouth, another thing that is disabled here [system boots in less the 7 seconds…] :wink: