Can't add Farsi/Persian keyboard

Hi friends!

I am using openSUSE LEAP42.2 KDE, and I can’t for the life of me figure out how to add Persian keyboard to my system.
In YaST>System>Language there’s no Persian/Farsi, only Arabic, same with YaST>Hardware>System Keyboard Layout.

Any help would be greatly appreciated!

those are two different things. YaST > System > Language is to make software output messages in a language.

The other one is for configuring that you have such a keyboard to input characters.

BTW, as you do not see Persian in YaST > System > Language, I assume you should install from YaST > Software > Software Management and then from the View menu (somewhere up-left) choose Languages. Scroll down to Persian and check for installation, etc.

I doubt if that will add a Farsi keyboard to the other list, but you should check that of course.

Hey, thanks for the explanation! I went on and installed Arabic Language and also Farsi from Software Management > Languages, while I still couldn’t choose Farsi from System Keyboard Layout, there was a thing added to my system tray, called the IBus Panel, from which I could add other keyboard languages, and Persian-isiri(m17n) was amongst them. While the whole thing looks pretty weird (like, for instance, when you choose the Farsi language in the system tray, instead of FA you see a gearwheel), it gets the job done. Not quite sure which package installation made this happen though.

However, now I am presented with a new problem, no matter what I do, I cannot switch between the keyboard layouts using keyboard shortcuts. I assumed the “Next input method” in IBus Preferences is what chooses the keyboard shortcuts, but no matter what key combination I choose (shift+alt in this case), it does not seem to work.

I still wonder if there is any other form of farsi keyboard available for openSUSE.

Ok, i managed to find out what was wrong with this, I was so caught up trying to make this work using the settings found within the YaST Control Center that I completely forgot about other things, such as searching for Keyboard in the Application Menu.
Anyway, what I did was, I opened the Application Menu and searched for Keyboard, and funny enough, chose Keyboard from the list, then the Keyboard – System Settings Module window opened up and the rest was pretty self-explanatory.

So, now I wonder, is there a way to get to that window from YaST?

I assume you used a desktop (KDE) configuration. That will only apply to the user you were loged in as (and basically only when that user is loged in using KDE, although other DEs might see this). Not to the system. And thus it is not a YaST task.

Did you install the following packages (language code “fa”)?

  • farsi-fonts
  • translation-update-fa
  • aspell-fa
  • yast2-trans-fa
  • libreoffice-l10n-fa
  • ibus-m17n
  • MozillaFirefox-translations-other

There is a KDE package named “kde-l10n-fa” but, it’s for “KDE4 Plasma” and NOT for “KDE Plasma 5”.

I see,
Thanks for your help!

Yes, I have installed all of the packages you mentioned but have also downloaded “kde-l10n-fa” should I get rid of it or something?

Depends on which KDE you’re using: “KDE4 Plasma” (Leap 42.2 option) or “KDE Plasma 5” (Leap 42.2 standard).

I booted the Leap 42.2 installation DVD to inspect which languages are possible at installation time: Farsi (Persian) is not possible and, if Arabic is selected then, the installation changes absolutely to Arabic.

Maybe you could consider contacting the openSUSE installation maintainers to ask if Farsi support at installation time is being considered.
[HR][/HR]The following KF5 statistics are available from the KDE organisation:
KDE Localization: Apps » stable-kf5 » Teams: <https://l10n.kde.org/stats/gui/stable-kf5/team/&gt;
KDE Localization: Apps » stable-kf5 » Farsi (Persian): <https://l10n.kde.org/stats/gui/stable-kf5/team/fa/&gt;

@TheAlbatross:
Apropos “kde-l10n-fa”: on taking a closer look and, checking against “kde-l10n-de”, both have KDE4 components and, both pull in “kio-extras5-lang”, which is a KF5 package.

Therefore, “kde-l10n-fa” should be OK with KDE Plasma 5.

I see, thanks a lot for your help!