Can't Access USB HDD

Hi All,

I have used Ubuntu a few times in the past but never really had any issues with it so im still quite new to Linux as far as dealing with problems go. I decided to give suse a try but I cant seem to access my USB HDD.

If I type fdisk -l in a terminal my drive shows up but I cant find it anywhere. Im more used to Gnome but decided to try KDE for this install so it possible im just not looking in the right place but when I insert a USB flash drive its easily found under the computer section of the kick starter/app launcher button.

Here is my fdisk -l(I have to run this as root, is that normal?)

gandalf:/home/iain # fdisk -l

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000f0033

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         262     2104483+  82  Linux swap / Solaris
/dev/sda2   *         263        2873    20972857+  83  Linux
/dev/sda3            2874       77825   602051940   83  Linux

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8d399bc0

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       60802   488383488    7  HPFS/NTFS
gandalf:/home/iain #

Could someone help please?


just remembered a while ago I tried to reformat the drive as fat32 but windows would only let me select NTFS or exFAT so I selected exFAT, does SUSE read this type of filesystem?

I think not

I tried to reformat the drive as fat32 but windows would only let me

This is most odd!

First off, to answer your question about “fdisk -l”, you do need to run this command as root. That is normal.

Second, I must ask about your USB hard drive. Do you leave it connected to the same USB port all of the time while running openSUSE?

If the answer is Yes, then I suggest you add it to your fstab file located in the /etc folder. You must edit the file as root to make any changes. I use an external USB drive and the entry in my fstab is as follows:

/dev/disk/by-id/usb-ST315003_41AS_ST31500341_9VS16YJQ-0:0-part1 /Software            ntfs-3g    Defaults              0 0

This entry was created for me using the Yast Partitioner (menu/Yast/System/Partitioner). To do this you run the Partitioner, Find your usb drive/partition on the right, right click and pick edit. By default the drive will not be formatted. You must select the mount bullet and then enter a folder name for the mount to occur. In my case I entered “/Software” without the quotes. In this entry, you do not see /sdb, but rather the drive UID as it is called. By using the UID, I could change the USB port I am connecting to, but the mount would continue to function even if the drive designation might change because I changed the USB port.

You can make this modification manually, and use the /dev/sdb1 designation instead of the UID, if you do not know it. In the case of my example, this is a Windows NTFS partition type. By using the Yast Partitioner, I do not have to figure that type of information out. However, if you are inclined to do a manual edit of fstab, you would use the following command if you use the KDE desktop:

kdesu kwrite /etc/fstab

You must enter the root password, make you changes, save the file and reboot your computer for the changes to go into effect.

Thank You,

The stated filesystem in fdisk -l says NTFS but I can’t remember switching it back. Just incase I did, is there any advice you could give me to see if I can access the contents of the drive?

One thing I did stumble upon as I was looking around was finding the object in /dev there is sdb and sdb1 if i clikc that, i can select to open with dolphin but it is blank, would this be a valid way of trying to view the contents via the gui?

Hi jdmc,

Thanks for the reply. It is always connected to the system and the port doesnt change but I tried disconencting and reconnecting but it didnt seem to change anything, I shall try your suggestions and see what happens, many thanks.

Just tried that but an error comes up advising it is not possible to mount a device with a non existent or unknown file system. Must still be running this exFAT. If I didnt have all my pics and stuff on it id happily re-partition and format the thing.

smexymage you have a couple of options. If you have any data on this drive, you must connect it to an OS (such as Windows that can read it) and save your data. Next, if you want to use it with openSUSE, but continue to use a Windows type partition, you must reformat it using Windows. openSUSE can not create a NTFS partition, even though it can read and write to it. So, if you want to use NTFS, format it when pugged into a Windows machine. Next, go back to Linux and use my partitioner instructions to add it to openSUSE and your fstab file. Now, the Yast Partitioner can create FAT32 partitions and any of the other supported Linux partitions. You can use the Yast Partitioned to create any of these other partition types if you don’t want or need an NTFS type partition.

Thank You,

The stated filesystem in fdisk -l says NTFS …

You are correct, fdisk only tells what it sees in the partition table. It sees the number that corresponds to HPFS/NTFS. But that does not mean that there is an fs of that type on it. It does not even say there is any fs on it. It is just a number put there during partitioning.