Canon PIXMA MP520 Some programms wont print black text.


I have this printer Canon PIXMA MP520 (got it today, used), I’ve just installed new cartridges and plugged to my openSUSE 12.1 box. I used Yast to configure printer, it downloaded drivers (I’ve chosen simplified one, but same problem with another driver too). It prints the test page just fine. I’ve tried to print GnuCash report and I get no black text, only blue underlined text (in report it looks like a link). I’ve tried printing to PDF file and then using Ocular to print, but same problem.
I’ve tried copy-pasting all report to LibreOffice and printing, and all seems to print OK from LibreOffice.
I’ve tried playing with advanced settings but with no luck.

May be someone knows why this is happening or how to fix that.

If you need more details, like cups version, driver version, or anything else, please say so, I’ll provide.


Take a look HERE

Thanks cmcgrath5035, kudos,

I think I’ve found this before but did not pay enough attention as YaST found drivers for my printer. RPM’s from Canon work just fine, and GnuCash now prints it’s reports as it should. … Now for the scanner part :slight_smile:

Thanks again,

For scanning, I use Viewscan.
Not free, but works very well with stand alone scanners and HP PSC’s.
Perhaps you can testdrive it with you Canon.

Good luck.


I’ve tested scanning with VueScan, works great, but you have to buy it to remove watermarks. I’ve also tried Skanlite (Comes as default with openSUSE KDE), and Canons own ScanGear MP, both of them work without any problems.
So I have fully working All-In-One.