Canon PIXMA 475 Printer

Does anyone know how to use this printer with Suse Leap? I’ve added the printer using the CUPS page, but when it comes to selecting the printer driver the model number is not shown in the drop down list. I’ve tried using the driver for my previous printer, a PIXMA 435, but this doesn’t work; nothing is printed.
I am able to use the printer from Windows XP running in VirtualBox, but I assume it is talking to the printer directly and doesn’t use any linux support.
According to the Canon driver page, this model has been available since 2014 so I’m not sure why it isn’t available - perhaps some propriety issue?
I’ve also tried installing the cnijfilter-common package from

https://software.opensuse.org/package/cnijfilter-common

, but cannot find anything that looks like a common printer driver in the configuration drop down list.
Any help would be appriciated. Let me know what other info you need.

Mike Railton

Can’t help you with that printer really, but I see there’s a driver .rpm package available on Canon’s homepage.
Did you download and install that?
The exact download link is https://www.canon.at/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mx_series/pixma_mx475.aspx?type=drivers&driverdetailid=tcm:84-1144378&os=Linux%20(64-bit)&language=#disclaimer .

You’ll get a .tar.xz archive that you need to unpack, and that contains the actual rpm packages and a script to install them.

From what I can see in Canon’s .tar.xz archive, it consists of two packages, cnijfilter-common and cnjfilter-XXX, you need the latter as well as it contains the actual printer driver.
But that link you posted is the wrong driver for your printer model AFAICT.
Better download it from Canon directly via the link I posted above. That contains cnijfilter-mx470series, and should support your printer.

You’re mistaken - you did help:)

That is the package I downloaded, but the first time I tried to install it there was an error regarding packages not being where they should be. That is why I tried the other option.

Indeed, that didn’t seem to do anything.

And now it works. I downloaded that installer and tried again. At first it complained about the missing common package. I installed that manually - I had to accept a broken dependency - and then reran the installer. I can now print again. Thanks wolfi323, that’s the third time you’ve got things going again for merotfl!