Canon Imageclass MF264dw

Has anyone had any luck install this or a similar printer? I haven’t been able to get this to work.

I can imagine that there are people here that like to help out with installing a printer. But then they need a report of the steps you took and where you got stuck and why you think so (e.g. error message, or whatever). You description above will not help them.

Sorry it’s a common printer right now, so far I’ve tried setting it up as a network printer, I did find it but fail to get a working ppd/driver. I also tried connecting it via usb to have that run as a print server hoping that would work, but I’m having the same issue and failing to get it working even directly connected via usb. Small Business network, 1 laptop, 1 desktop, both running openSUSE Tumbleweed.

Did you try configuring with YaST or whatever? I assume that you did not just plug it in somewhere assuming that a miracle should occur.

I can’t vouch for the accuracy of this, but may be worth a look…

https://tutorialforlinux.com/how-to-install-canon-imageclass-mf264dw-mf267dw-mf269dw-driver-for-gnu-linux-distros/

Drivers:
https://www.canon-europe.com/support/consumer_products/products/fax__multifunctionals/laser/laserbase_mf_series/i-sensys_mf264dw.html?type=drivers&driverdetailid=tcm:13-1506758&os=linux%20(64-bit)&language=

Unzip and read the UserGuide.html in the Documents directory.

PCL6 is also supported.

I got the printer to work but not the scanner. Not sure how to do that. Here my instructions I wrote up because it was a pain but it did work in the end:

  1. Download the appropriate drivers:
    https://www.usa.canon.com/internet/portal/us/home/support/details/printers/black-and-white-laser/canon-imageclass-mf264dw?tab=drivers_downloads

  2. If Windows, run installer.

If Linux:
In a Terminal, extract the .tar.gz file:

$ tar xvzf *[path/filename]* -C *[path of destination folder]*

For the rest of the instructions, I’ll assume you downloaded the file linux-UFRII-drv-v540-usen-20.tar.gz to the Downloads folder, then execute the command in Terminal to extract the files into the Downloads folder:

$ tar xvzf  ~/Downloads/linux-UFRII-drv-v540-usen-20.tar.gz -C ~/Downloads
  1. The folder linux-UFRII-drv-v540-usen containing the extracted files has an executable file install.sh but it seems that’s for a Debian/Ubuntu install (requires apt) so don’t run that. (Note: for Debian/Ubuntu users you can also follow the rest of the instructions by changing the RPM folder name to Debian and use apt instead of the rpm or zypper command.)

  2. Enter the following commands in the Terminal/Console:

If you have a 32-bit CPU, enter:

$ cd ~/Downloads/linux-UFRII-drv-v540-usen/x86/RPM/
$ sudo rpm -i cnrdrvcups-ufr2-us-5.40-1.i386.rpm

If you have a 64-bit CPU, enter:

$ cd ~/Downloads/linux-UFRII-drv-v540-usen/x64/RPM/
$ sudo rpm -i cnrdrvcups-ufr2-us-5.40-1.x86_64.rpm

I prefer using zypper instead of the rpm command:

$ sudo zypper install cnrdrvcups-ufr2-us-5.40-1.x86_64.rpm

If needed, install dependencies first.

  1. Nagivate to the PPD folder
$ cd ~/Downloads/linux-UFRII-drv-v540-usen//PPD/RPM
  1. To install the PPD files, execute:
$ sudo zypper in ./*.rpm
  1. Open web browser like Firefox or Chrome

  2. Open CUPS. Navigate to: localhost:631

  3. Click on Administration in the main menu

  4. Click on the Add Printer button. (You’ll need to enter the root username and root password; if you don’t know what that is, you can always set a new one if your user is part of the sudo group)

  5. Under Other Network Printers, select Internet Printing Protocol (ipp) and click Continue.

  6. For Connection, enter:

ipp://[ip address of your Canon MF264dw printer]

Click on Continue.

For example, my printer’s ip address is 192.168.0.11 so I’d have to enter:

ipp://192.168.0.11

If you don’t know what you’re printer’s ip address is, check the settings on the printer: Press Menu > Network Settings > TCP/IP Settings > IPv4 Settings > IP Address Settings > Check Settings > IP address)

  1. Enter the name of the printer entry (no spaces). I entered:
    Canon-MF264dw

You can also specify a description and location and check the box if you want to share the printer over your network.

  1. Select the Make and Model:
    Make: Canon
    Model: Canon MF260 Series UFRII LT

Click on Add Printer

  1. You can set defaults for your printer. From the CUPS menu, click on Printers. Click on the MF264dw printer link. From the Administration drop down box, select Set Default Options.

Try printing a test page. Hope it works for you as it did for me.

Cheers,

Dad4Linux