Cannot start Windows Vista after failed Suse installation

I wanted to try openSuse alongside with Windows Vista and Ubuntu. During the installation Suse wanted to delete my Windows partition. Of course I denied and stopped this installation, but now when starting my computer, the boot menu gives Vista, Ubuntu and Suse as a choice, but if I choose Vista, the Suse installation process is starting instead of Windows, there is no way to get Windows started (fortunately Ubuntu is working so that I can write this message).
How can I get Windows starting?
(This behavior of openSuse really makes me angry!!)
Hopefully somebody knows to solve this problem.
Thanks in advance
Dieter

It shouldn’t have written or delete anything without your permission. Did you carefully review the proposal before you hit install, then hit cancel? Or did you hit install before realizing that it was going to delete your Windows partition? If it’s the latter, then it’s probably too late now. There should have been a page with a proposal before you do anything that will let you leave the installation with no change to your machine.

I read the proposal to delete my windows partition and immediately stopped the installation, so I never hit install. I cannot understand why the boot menu is changed in such a way. The question is, can the boot menu be “educated” to do what it is saying?

You ran the installer from within windows didn’t you!
BIG mistake.
Get your thinking cap on and read, read, read here:
Update from Suse 11.0 to 11.1 - Page 2 - openSUSE Forums

Thanks for the info. I tried the Vista Bootloader Recovery CD, but the boot loader would not change (the repair program could not find any mistake), finally I tried the last recovery point, also with no result.
Any other possibilities, or must I recover the whole Windows system?

If you can’t figure it out, that would look like the best option.
If you need any files off windows, use a cd like parted magic and copy them over to a storage device

Next time use the suse cd or dvd and boot from it, don’t run it in windows!

@caf4926 looks like a candidate for study and write up is:

“Installing from windows: howto root out the openSUSE installer from windows when you abort the installation program before it finishes”.

Thanks again for the help. In the meantime I could solve the problem by using method 4 (manually by using “bcdedit.exe” as described in the Microsoft support pages). The boot menu now only shows Windows Vista(recovered), Ubuntu has disappeared, but as Ubuntu appears to have many bugs, I can live without this and will give openSuse another try, now booting directly from the DVD.
Best regards
Dieter

I’m trying to investigate this widely-encountered fault Dieter.

I’ve been trying to simulate your problem. I can’t get vista booting to break like yours did. I tried what you said: I waited until it suggested to me that it would mount my partition as /windows/C. Then I stopped the installation right there in various ways (like pull the plug, click the “Abort” button, open the CD drawer etc) but it always gave me the option to boot to vista OK after the reboot.

Can you remember exactly what you did to get this fault, so I can maybe get it too? [and then I could investigate a simple solution for other poor folk who might lose their vista because they don’t know what to do to fix it].

I have seen some complications in this where the user mounts the .iso in a virtual drive like in Alcohol 120
Don’t know if that makes any difference.

As written in my first question, I started the installation process from within Windows Vista (not from booting), this added to the start menu the choice of openSuse. Then booting with the inserted openSuse-DVD the installation process was chosen but stopped when openSuse wanted to delete my Windows partition. My harddisk had partion C with Windows Vista and partion D with Ubuntu, but there was more than 100 GB free space on D. I stopped the installation, but then Vista could not be started, the choice of Vista (first item in the start menu) always loaded the Suse installer.
As described I could solve the problem, the start menu now only shows Vista recovered.
Of course I wanted to try openSuse and started the installation by booting from the DVD, after having reformatted partition D. So I thought openSuse would choose partion D with about 130 GB free space. Strangely enough openSuse still wanted to delete my Windows partion, saying that due to an inconsistent file system the partion could not be changed. As partition D was freshly formatted (NTFS) and checked with chdsk, I cannot understand why openSuse does not choose this partition (when I first tried Ubuntu, partition D was chosen, so I could install it; strangely enough I have now tried Kubuntu, and it also wanted to delete my Windows partion).
So in the moment I don’t know what is happening, and changing the partitions manually with openSuse appears to dangerous to me, I cannot afford to destroy my Windows.
Best regards
Dieter

Sorry for the late response, I had been in holiday

I find it difficult to believe that suse would offer to delete winders!
It has never offered such to me.

You need to read up on partitioning a bit, as you seem confused:)

Partitioning - Windows Live

Custom Install.mpeg.rar - Windows Live

Default Install.mpeg.rar - Windows Live

11.2 Slideshow Images - Windows Live

dieterduennwald wrote:
> As written in my first question, I started the installation process from
> within Windows Vista (not from booting)

Why you did it that way?

Quote (cite: http://software.opensuse.org/112/en):

  1. After having successfully downloaded the ISO image(s), burn the
    image(s) with your favorite burning application to a DVD or CD…

  2. Boot from the DVD or CD. In case your computer does not
    automatically boot from CD/DVD, open the BIOS setup to allow booting
    from CD or DVD.

  3. Instructions are available as follows: [Links to specific and
    detailed instructions sniped.]


palladium

Response to caf4926
It may be hard to believe, but here is the text of Suses proposal:
in red:“Delete partition/dev/sda1(10.00GB)
Delete Windows partion /dev/sda2 (144.04GB).Resize impossible due to inconsistent fs.Try checking fs under Windows
Delete Windows partion /dev/sda3 (139GB).Resize impossible due to inconsistent fs. Try checking fs under Windows.
in black: Create extended partion /dev/sda1 (293.04 GB)
Create swap partition /dev/sda5 (2.01 GB)
Create root partition /dev/sda6 (20.00 GB) with ext4
Create partition /dev/sda7 (271.03 GB) for /home with ext4”
I cannot understand why my file system should be inconsistent. Partition D was newly formatted with NTFS, and chkdsk did not find any mistakes. So Suse should use partion D for the installation, as Ubuntu did the first time. But now also Kubuntu wants to delete my Windows. So I have the feeling that during the first aborted installation of Suse something has happended to my file system which Windows does not notice or cannot repair.
Regards
Dieter

NTFS in vista was a “new” version of NTFS compared with all earlier versions. The Linux apps for handling NTFS seemed to have a few difficulties with NTFS created in vista. Ppl using openSUSE 11.0 and 11.1 were particularly noticed by me as encountering strange partitioning behabviour when installing openSUSE near vista partitions.

The experts at ntfs-3g have probably got the new NTFS wired now, and I notice that Gparted is not cracking up any more on NTFS ex vista. But I wouldn’t be surprised if openSUSE’s installer still was dodgy re NTFS ex vista (and win7 I suppose).

I think that’s likely the problem with the interaction between openSUSE’s installer and the vista partition.

Please buy and use Windows7. Windows Vista is in my eyes obsolete.

I would need to see your original fdisk -l report - The exact partition layout.

I know that’s not much help and maybe not possible. But all the installs I have done I have never had anything like this suggested in the installer. Mind you I always have my partitions in place correctly before install.

You understand there can only be 4 Primary partitions and that an extended partition is a Primary.
I have seen a number of win7 examples recently where there is a boot partition, a recovery partition and the win7 install partition and a data partition.
So 4 primary
I imagine this might cause some fun, but you just wouldn’t try and install with all those in place, because it’s not possible.,

swerdna wrote:
> NTFS in vista was a “new” version of NTFS compared with all earlier
> versions.

OH! so MS decided to once again practice their old trick of
“improving” something until it still works in Windows but LOCKS
everyone else out…

their software design department’s favorite saying:

It ain’t done, until Linux won’t run!


palladium

Pilgervater wrote:
> Please buy and use Windows7. Windows Vista is in my eyes obsolete.

Windows7 is just Vista-patched and is already an obsolete malware
magnet, like all its ancestors!


palladium

I’m recommending you for the prize of most biased Linuxer for 2010 lol!