Cannot set Konqueror as File Manager

The first thing I did with my new 13.1 installation was to change the default FM from Dolphin to Konqueror from the Default Applications of System Settings.
A few minutes ago, I needed to test a web site, so, I opened a new Konqueror window and switched to a web browser profile. After that, I cannot open Konqueror as the default FM. I switched even to Gwenview, but, still, the File Manager menu entry opens Dolphin.

Then, I tried to “pin” konqueror in FM profile, as I used to have until a few minutes ago. I failed.

So, I need to somehow reset everything and try again. How?

I managed to pin the correct konqueror:
I opened konqueror from CLI with

kfmclient openProfile filemanagement

.
Then I pinned it. Now, I have Konqueror as FM but still, Dolphin is the FM for the rest of KDE.

Have you tried System settings>Default applications>File manager?

Please re-read my original post…

OK - normally using Konqueror as a browser involves invoking konqbrowser. Has the temporary use of Konqueror as a web browser without invoking it using konqbrowser caused a settings conflict? I know it shouldn’t but I always remove Firefox because it causes a similar conflict.

Try setting Konqueror as Default File Manager and konqbrowser as Default Web Browser and see if that solves the problem.