Cannot run nvidia-settings - Error:The control display is undefined; Please run nvidia-settings --h


Shortly after openSUSE 11.4 / KDE was released I updated one of my systems (Pentium D dual core, 3GB memory, nvidia GeForce 6700 XL card with 2 monitors attached to it. The 2 screens actually worked as one big screen via nvidia-settings program.) to openSUSE 11.4 / KDE 4.6.
Initially I used the nouveau driver with only one monitor attached. That worked fine but I was missing my 2nd display.
Last week I decided to try the proprietary nvidia driver in combination with nvidia-settings program to reactivate the 2 screens mode that actually worked as one big screen…
I used the 1 click install for Geforce 6 and newer cards from the following URL:
SDB:NVIDIA drivers - openSUSE
The system said that the install was successfull and that i needed to reboot. After the reboot the system booted in run level 3, as run level 5 was skipped (splash rng-tools) As stated in the above URL I looked into the troubleshooting URL - SDB:NVIDIA troubleshooting - openSUSE
but did not find a solution.
After that I tried from the 1st URL - SDB:NVIDIA drivers - openSUSE the “repository
way”. My nvidia card is a Geforce 6700 XL - VGA Compatible Controller and the kernel in use is I have added the nvidia repository in yast and install the required packages:
The system installed in addition:
and I selected in addition:

I restarted the system but it still booted in run level 3, as run level 5 was skipped.

I tried the “whatsever” options 1-5 from the following URL :
SDB:Configuring graphics cards - openSUSE
without success as the system still booted in run level 3, as run level 5 was skipped.

I wonder why I cannot run nvidia-settings from the run level 3 since the system generates the following error: The control display is undefined; Please run nvidia-settings --help for usage information.

Any idea for help??? before I continue with “whatsever” option 6 from the following URL :
SDB:Configuring graphics cards - openSUSE.

Looking through dmesg I found the following:

line 834
NVRM: Loading NVIDIA Unix x86 kernel module 173.14.28

line 869-872
NVRM:API mismatch: the client has the version 270.41.06, but
NVRM:but this kernel module has the version 173.14.28 Please
NVRM:make sure that this kernel module and all NVIDIA driver
NVRM:components have the same version.

What went wrong and how to correct???

Regards, Frans

Nvidia settings looks like an X app to me so needs a graphics display window. There are numerous safe mode settings available on my installation from the menu that appears when you boot up (not the 1st boot splash menu, just use safe mode there). One of the terminal prompts offered seems to be bash running under X. You could try from there.

Also nvidia seem to use --help as an option and that may work from the prompt and give you a clue.

I to found that the one click install didn’t work. Suspect it’s well out of date.

I have posted a method using yast and a specific repo but only for one screen. I haven’t tried adding a 2nd card that way yet but probably will at some point.


This means that you need to get the latest Nvidia driver, or recompile the kernel module. However!! The latest X version does not play will with Nvidia.

I suggest trying to install the driver the “hardway” (it’s really very easy) by just running the install script from Nvidia’s website. You’ll probably need to zypper the kernel headers and gcc.

Good luck.

Hello, Thanks for the replies. I solved the problem by going in yast/software/software management and flagged all installed nvidia programs for deletion. The system executed this task and asked for a reboot that resulted in a working openSUSE 11.4 /KDE 4.6 system via the nv driver.

I have re-installed the required nvidia programs via yast, from run level 3 and changed the /etc/X11/xorg.conf file sothat the driver is now nvidia instead of nv.

I run modprobe nvidia to activate the driver and run rcxdm start to start the X server and finally I could log in the openSUSE 11.4 /KDE 4.6 system now via the nvidia driver.and finalised the configuration of the nvidia-settings program to set up my 2 screens as one big screen.


Regards, Frans