Cannot revert to Opensuse Bootloader

HI All,

Much searching hasn’t given me an answer to this yet but hopefully someone can help me out / point me in the right direction.

I’ve been using OpenSuse 12.3 happily for a few months and the Grub2 bootloader had the graphical OS branding. The other evening I installed Mint 15 on a new partition and it created it’s own Grub2 loader with Mint as default and OpenSuse further down the list. It also reverted back to a basic text look without any graphical menu.

I dont have any problem booting into either system but I’d like to go back to the Opensuse 12.3 themed Grub2 (and add in the Mint partition).

I’ve tried played about with the bootloader configuration in Yast but nothing changes, I think that the computer is using another Grub2 on the Mint partition (it does have Ubuntu at the top of the menu screen).

How do I kick the original Grub 2 back into life firstly?


You can use the openSUSE installation media to repair the bootloader.

No repair needed
Just boot to openSUSE
Open a terminal and do this

su -
grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda

Once it’s done

Cheers guys. Yes I did know about repairing from the installation media, but i) as Caf said it didn’t require a repair just to re-establish the link to the original Grub and ii) I haven’t got the disc (leant it to a mate). Anyway, Caf, your method worked a treat, all back to normal thank you.

No for the second part. I now have a partition with Mint 15 installed that currently doesn’t appear in the Grub2 menu of my Opensuse installation (as expected). In the original Grub(1), it would have been a simple case of going and finding the entry in the Mint version of “menu.lst” and duplicating that in the Opensuse menu. Unfortunatly, I can’t get my head around this Grub2 and could really do with being led-by-the-hand on how to do it.

Anybody fancy being my guide?

My partitioning is:
sda1 (unknown)
sda2 (ext4) / Opensuse
sda3 (ext4) /home Opensuse
sda4 (extended)
sda5 (ext4) Mint 15
sda6 (swap)

(I’m not sure why Mint is showing as only the one partition).


Mint and Ubuntu typically put everything in one partition /
Unless you tell it to do otherwise

I have had no issues with openSUSE finding Mint - ever

But try mounting the Mint partition in openSUSE and then run the code I gave you again

I think you’re right about the single Ubuntu partition. Anyhow, when you suggested I mount the Mint partition before running the Grub2 config I wasn’t sure if it was mounted the first time I ran it. So I just made sure and did the Grub2 config/install again (just to be certain I checked after and the Mint partition was still mounted). Unfortunately there is still no Mint (or for that matter anything extra) in the Opensuse Grub 2 menu. I had a quick check before writing this and found /boot/grub/grub.cfg in the Mint installation but no Grub2 folder, even though when I had Mint doing the bootload the menu had “Grub-2” on the top of the page.


I’m not too sure then.
What sort of partitioning are you using? Is it LVM
If you are not sure, post the result of this:

su -
fdisk -l

Or if that complains because it finds a GPT table use:

parted -l

Don’t panic, we can get you back to Mint…

I believe it LVM but just to make sure here’s fdisk’s output:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a206b

Device Boot Start End Blocks Id System
/dev/sda1 2048 4208639 2103296 82 Linux swap / Solaris
/dev/sda2 * 4208640 46153727 20972544 83 Linux
/dev/sda3 46153728 345855572 149850922+ 83 Linux
/dev/sda4 345855998 625141759 139642881 5 Extended
/dev/sda5 345856000 619395071 136769536 83 Linux
/dev/sda6 619397120 625141759 2872320 82 Linux swap / Solaris

I’m happy enough with Opensuse apart from trying to get my HP Wireless printer working, that’s proved a nightmare (and a problem for another day/forum). I had a play with the Mint 15 off Linux Formats cover disc and it worked with my printer so I decided to install it alongside Opensuse just for printing purposes and ended up messing up the bootloader.


It’s not LVM
But of course the partitioning is a little messy because your partitions were not all prepared in advance. So Mint has shrunk space off the openSUSE /home (at least that’s how it reads).

Personally I found a few bugs in Mint 15 that were too annoying and I prefer Mint 14. And I never install from Linux Format Cover disk, but only from the official source. Not that there is anything wrong with LXF. I wrote an article for them in the latest issue.