Cannot Remove empty file

I was copying an .avi file to an external hard drive and half way through the copy the drive reset and required remounting. Consequently I have an empty .avi file on the hard drive. I tried to recopy the file and overwrite, but I keep getting *‘Could not write to media/harddrive/filename.avi’. *I tried to rename to file to be copied but got the same response, I cannot delete the empty file either, as I get an error telling I cannot delete it. I have tried to do this as the user and root with the same result.
Any other file I tried to copy onto the external hard drive is fine, just this one zero length file and the file I was trying to copy, the original of the file. I also tried to delete the file on another computer but couldn’t
External hard drive is a WD elements ntfs, which works great except for this glitch.

OK, swapped over on my dual boot to win7 deleted zero length file and copied original without problems. I am still puzzled as to what happened under openSUSE to cause the problem though.

Filesystem damage. Booting Win repaired it.

On 03/02/2011 09:06 AM, Dwarfer99 wrote:
> WD elements ntfs

sounds like a great question to ask of an NTFS expert…

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11