Cannot open password protected archives with Ark

Each time I try to just open a password protected archive with Ark it just shows a “Loading file” progress bar, but nothing happens after several minutes. And if I just right-click and select “extract” extracts nothing. It doesn’t even ask for the password at any moment. I also checked the help typing “man Ark” in the console, but found nothing related to passwords. Has someone successfully opened archives with password with Ark? Or is it still buggy?

And on a side note, I can open normal .rar files, but cannot compress files. It says “failed to locate program RAR in the PATH”. I thought Ark was all self-contained. Do I need to install something else?


I have never tried passworded archives.

To the other issue: Have you installed rar?

I have no problems with ark opening password-protected zip files. Try starting ark from a terminal and open a protected file, see if you get any warning messages.
Also, AFAIK there are some license restrictions with the rar compression algorithms, so it can’t be installed as default, you have to install it yourself. To further confuse the issue there is (or was) also a rar2 package, for another version of rar IINM.

Do you mean Packman’s Rar 4.0.1? (I found that one in Yast, didn’t find anything like “rar2”).

I’ve never used Ark from the console. I’ll give it a try. Haven’t you tried with pass-protected rar files?

If nothing helps, you can try 7-zip via Wine. In my opinion, it works much better than any linux archiver…
It’s quite strange, that there is no linux version, since this is open-source software.

On 08/01/2011 08:56 AM, sobrus wrote:
> … 7-zip … there is no linux version

looks available to me:

openSUSE®, the “German Engineered Automobiles” of operating systems!

Yes, I have extracted password protected .rar archives with Ark (Ark 2.16 on KDE 4.6.5; 64-bit). [ETA] It works both with the right-click commands (eg “Extract here”) and with opening the archives in Ark ‘properly’.[/ETA]

But I also remember that used to have problems with earlier versions, and I had to use ‘unrar’ at the cli. Luckily, Konsole understands drag-and-drop, which makes things much easier.

How do you open files “properly”? With console? Do you specify the password?

Ah, sorry. With ‘open properly’ I simply meant what happens when you just (double-)click a file in Konqueror or so, i.e. when Ark shows the contents of an archive in a window. Maybe I just should’ve said ‘normally.’ :stuck_out_tongue:

To open such a Password protected .rar archive I would have used the command

unrar x /path/to/file.rar /path/to/destination/

The command ‘unrar’ is not Ark.