Cannot Mount NFS export.


I am running OpenSuSE 11.3.
I cannot mount an export from a Redhat 9 NFS server.
I am able to mount the export from RHEL5, Ubuntu, Fedora, Solaris but not OpenSuSE 11.3.

This is the command I use from a Ubuntu Karmic box.
mount server:/exportdir /mnt -o vers=3,proto=udp

As I said it works from many other distros, but not sure why no go on this one. Can anyone explain this? Should I submit a bug? I noticed portmap is not used anymore and am wondering if thatmay have anything to do with it. The rpcbind is supposed to handle this from what I read…not sure if this is accurate.


So, you’re the next one bitten by this. Don’t worry, fixed in a moment:

In /etc/nfsmount.conf look for


change that to


Mind, you have to remove the “#”, change the “4” into a “3”.
Then do

su -c 'rcnfs restart'

I ran into the same problem, the solution was already on the forums. All fine now.

Hello Knurpht,

Thanks for the reply. I already have the Defaultvers set to 3 in the NFS mount.conf. Originally I could not mount anything via NFS and had to change this. However for this particular export, it will not allow me to mount it. I don’t know why but I get this error below.

mount.nfs: mount to NFS server ‘server:/exportdir’ failed: timed out, giving up

The version of NFS server on RedHat 9 may be old but I cannot get it to mount with any options. I have tried vers=2,udp vers=3,udp

Is this a bug? I can mount all other exports with no issues from the 11.3 box. I can also mount this Redhat 9 export from all my other distros. How can I trouble shoot?


Have you compared the fstab line to that of other distros?
Do you restart nfs after making changes, i.e. run ‘su -c rcnfs restart’ ?
I ran some tests here, mounting NFS shares here, no problems. I have “Defaultvers=3” otherwise nothing mounts.

Hello again,

Yes, the same mount command line that works on RHEL5 or Ubuntu to mount this RedHat 9 export fails on OpenSuSE 11.3 for whatever reason. I did do the su -c ‘rcnfs restart’ and it did not help. I also rebooted. It worked fine on SLED 10 and 10.2.

I do mount about 12 NFS shares no problem from this 11.3 box, however mounting the shares from the RedHat 9 server I cannot. I appreciate your reply, do you know if this is bug worthy?

Thank you