Cannot install rpm's

Hi, i’m relatively new to linux/unix so please bear with me. I am trying to install a simple oracle DB on a linux box, the version of oracle i have requires several packages to be installed before running the Oracle Installer.

I ran the command:

rpm -ivh package_name.rpm

and the following happens:

repoman:/home/wfet/stage/Packages # rpm -ivh pdksh-5.2.14-30.src.rpm
warning: pdksh-5.2.14-30.src.rpm: V3 DSA signature: NOKEY, key ID db42a60e
1:pdksh ########################################### [100%]

Then when I run rpm -q package_name it tells me that the package has not been installed.

Does anyone have any ideas?

Thanks in advance.

What you installed is a source RPM. See the .src.rpm at the end of the filename?

To cut to the chase, a .src.rpm is not what you want. Get the RPM package pdksh-5.2.14-30.<arch>.rpm and install that. Better still, install it from YaST, I’m sure there’s a pdksh package in openSUSE’s repos.

Do you know of any decent rpm repository’s, the one I have been using is

Thanks for your help.

DO NOT DO THIS EVER AGAIN. What you did is simply you tried to hammer mandriva rmps into openSUSE. That can only do bad things. Really bad, so please do not do this again. rmpfind is good, but make sure you get the right version. The error message you got is most likely not supposed to be installed on suse. Be careful.

Good luck.

That’s a src rpm, you need to download the version for your arch eg
i586 i386 for 32bit or x86_64 for 64bit.

If your wanting to build from source, then it’s

rpmbuild --rebuild pdksh-5.2.14-30.src.rpm

In your case if you look down in the /usr/src/packages directories you
will see the files have been installed there…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 2 days 11:34, 1 user, load average: 0.15, 0.16, 0.12
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Can you suggest a safer way of installing rpms?

Stick with the RPMs provided by your distro and you should be fine. As mentioned already, use YaST to install software whenever possible.

Longer answer is, in order of preference:

  1. Use the standard repos
  2. If not, look for it in contributed repos (
  3. Use a generic Linux binary package, usually not packaged as a RPM
  4. Build from source or SRPM.

Installing a foreign RPM might sometimes work, but might also blow up in your face. You would have to know what you are doing if you are going to attempt that.

Thanks for the help.

You can also look here;

  1. Search here
  2. Or from the command line /sbin/yast2 webpin_package_search
  3. Another search engine
  4. Build your own at the build service

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 2 days 12:38, 1 user, load average: 0.07, 0.15, 0.11
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME