Cannot Install on vmware


 I'm trying to install openSUSE as a vmware workstation guest VM.       I'm running Fedora 29 as my host.

 I downloaded both the openSUSE Tumbleweed and the openSUSE Leap       ISO's
 I created a new VM in VMware setting it to "I'll install the       operating system later" and then set the cd/dvd device to point to       the ISO on my hard drive.
 I've also tried setting the VM to install from the same ISO file       in the setup screens (instead of selecting the "I'll install the       OS later option)

 I get the same result in both cases:

 the install screen shows up, I select "Installation" and hit       enter

 lots of text scrolls by and I see in the final segment on my       screen:

 VFS: Cannot open root device "(null)" or       unknown-block(0,0): error -6
  Please append a correct "root=" boot option: here are the       available partitions:
  Kernel panic - not syncing: VFS: unable to mount root fs on       unknown-block(0,0)

 Any assistance would be greatly appreciated.

 Thanks in advance...

Which version of VMWare do you use?
Did you customize the virtual hardware to different from the defaults?

I just did a test:

host: openSUSE Leap 15.0
VMware: Player 15.0.0
guest installation media: openSUSE-Tumbleweed-DVD-x86_64-Snapshot20181029-Media.iso
I used the setting “install os from ISO” and used all the default settings for the hardware.
No boot problems.
I stopped at the first graphical installer screen. So far everything worked as advertised.


With this setting (recommended), you do need to configure your virtual CDROM to point to the correct ISO on the last screen before actually starting the installation. You cannot successfully point to the correct ISO file before this last screen. If it’s pointing to the wrong image (eg whatever is in your physical CDROM by default) it’s anyone’s guess what you’re running.

IIRC the error you’re seeing is if your install can’t find a suitable storage device, which typically should be a newly created virtual disk file.

Although it doesn’t really work correctly, you can point to the ISO file instead of “I’ll install the operating system later” and do what it takes to make it work (I can’t remember what that is, it’s been so long since I’ve installed that way).

Also, don’t overlook the possibility you may have a corrupted ISO image. Check the SHA checksum.